Qubes with USB iso doesn't start

I installed Qubes 4.0.4 on an USB stick and additionally put an iso file on a Ventoy USB stick in order to get into a life image of Qubes.

Both won`t start on my Tuxedo Infinity Book S-17 Gen 6.

I tried with the usb Qubes installed. When I start it, it says Qubes is encrypted, so it can’t be started.

After trying with the Ventoy usb.iso files (I have got there several isos) it doesn’t start either. After checking in Bios I searched Ventoy usb, found it in EFI boot and entered, but after a black screen for some seconds, it started Kubuntu on my laptop, which is installed there.

I read several reports about not installing Qubes from an iso file on the Qubes Webside and in the Internet, but I didn’t find anything that could help me.

At the moment I don`t want to give up, but it seems very difficult to install Qubes, and I am not a Linux specalist.
I just bought this new laptop at Tuxedo, disabled Intell ME, and hoped to get Qubes running.

TUXEDO InfinityBook S 17 - Gen6
• Full-HD (1920 x 1080) IPS matt | 100% sRGB
• 8 GB (1x 8GB) 3200Mhz CL22 Samsung
• 8 GB (1x 8GB) 3200Mhz CL22 Samsung
• Intel Core i5-11300H (35W TDP) | Intel Iris Xe Graphics G7 (80EUs)
• 500 GB Kingston (NVMe PCIe)
• 250 GB Kingston (NVMe PCIe)
• Intel Wi-Fi 6 AX201 (802.11ax | 2,4 & 5 GHz | Bluetooth 5.2)
• Kubuntu 20.04 LTS

What should I do next?

I think your CPU might not compatible with qubesos 4.0.4 due to the generation lack behind. I think you should install the older versions of qubesos before you can upgrade it. Ventoy cannot work for booting the qubes os 4.0 due to multiple iso’s in place.

don’t, in the past usb in place i live were expensive so i tried this method, it very difficult to get thing work

it not “not compatible”, it just require many, many fixes

no, it not “lack behind” and it highly discouraged to install older release, which not supported anymore

1 Like

I got a black screen when trying to install 4.0.4 from USB on my system, 4.1 installed ok though.

1 Like

You were right, I managed to install 4.1.0-rc4 with an usb stick.

But, Qubes drives me almost to despair.

I cant use an additional monitor. Somebody said I would have to install kde. But this is at the moment impossible. On the other hand if I install kde with another method, than I have to choose kde in the beginning. But mouse support isnt working at the start so I can’t choose anything. I would choose kde if possible.

I cant install a program I tried 4 times to install MuseScore. It was installed 3 times, but I could not find it later on to open. I followed the instructions, how to install a package, but it didnt work. Probably I did something wrong.

  • Install software as normally instructed inside that operating system, e.g.:
  • Fedora: sudo dnf install <PACKAGE_NAME>
  • Debian: sudo apt install <PACKAGE_NAME>
  • Shut down the template. (Do not skip this step.)
  • Restart all qubes based on the template. (Do not skip this step.)
  • (Recommended) In the relevant qubes’ Qube Settings , go to the Applications tab, select the new application(s) from the list, and press OK. These new shortcuts will appear in the Applications Menu. (If you encounter problems, see here for troubleshooting.)

I wasn`t able to shut down some templates and to restart all qubes based on that template. It gave me some error messages.

I can`t install an additional keyboard, but that is not so important at the moment.

I cant install an appt: Network Manager applet in panel. It doesn exist in XFCE. I couldn` find it.

Almost everything I tried failed.

How can I restart all qubes based on that template in one go?

I just managed to install musescore at the approx. sixt attempt.

Hi Chloris, I’m sorry you are finding it difficult to get to grips with
Qubes. There’s a lot to get used to.
I think you need to take it very slowly.

On using an additional monitor, there is no requirement that you use
KDE. Of course you can use additional monitors in Xfce - why would you think

As to installing software, I am glad you finally managed to install the
MuseScore software.
But, had you followed good practice you would have missed many of these
issues. You could have cloned the template and installed the package in
to the new template - that way you would have missed most of these
I suspect that the problems you met here were because you were using the
same template as used by sys-net, or some other system qube.
If you meet this problem in the future there is no reason why you cannot
stop and restart sys-net, sys-firewall, etc. The only case where
this might be difficult would be where the template is used by sys-usb,
and you have a USB keyboard. In that case you could switch sys-usb to use
(e.g Debian) while you install software in Fedora and restart that template.

Without more information I cant understand why you could not install an
additional keyboard, (nor why you would want to), but I expect you had
some reason and hit some problem.

The Network Manager applet does exist in Xfce - if it did not there
would be howls of protest from the majority of users, as opposed to the
mutters from KDE users.
Without more information I can’t attempt to explain why you do not see it.

I never presume to speak for the Qubes team.
When I comment in the Forum or in the mailing lists I speak for myself.

I followed the instruction how to install kde and it really worked:

sudo-qubes-dom0-update @kde-desktop-qubes
and then sudo dnf install plasma-workspace
If u like to have Dolphin, too u need to install sudo dnf install dolphin manually, too.
Everything running in Dom0.
And then u can install sddm in dom0. sudo-qubes-dom0-update sddm and can
sudo systemctl disable lightdm and sudo systemctl enable sddm ,use the default kde display manager. For me that has better performance then Lightdm and I prefer it.

I have now kde and could log in. That`s great.

So I am a big step further.

In kde I wanted to add a monitor, but the whole Systemsettings/Hardware/Monitor settings are corrupt. There doesn`t even appear the laptop monitor. It is blank.

What can I do?

I could not find a Network Manager applet in KDE. In this version of KDE 5.18 it is probably not included. In never versions I saw it, because I had Manjaro installed.

After installing kde and dolphin and restarting
I wanted to open kde dolphin, but it was impossible. I tried in different qubes but no chance.
It seems that kde has big problems.

KDE has very few problems - it seems more that you have big problems.
Can I suggest that you open a new thread, rather than hang on this one,
since the problems you describe have nothing to do with this thread.

Also, you will need to provide far more information if you want any one
to help you.
“it was impossible” tells me nothing at all - in what was it
impossible? How did you try to open it? What did you see?

You should read this and try to
apply what you learn there.
If you help us by asking good questions, we can help you.

I never presume to speak for the Qubes team.
When I comment in the Forum or in the mailing lists I speak for myself.

i’m aware @unman reply, but you haven’t started a new thread so

you only install the plasma-workspace, so not setting here


if this the realty, probably kde already a dead project now

thanks for Your help.
I managed to use dolphin. It opened in a screen right to mine ,but in the desktop 1, and I managed to move it to the left, so I could see it. Strange, that there is a second screen.

I know that I am the problem and not kde, but I am a newbie at qubes and need a lot of patience from You and from myself, millimeter by millimeter I am learning. thanks

I installed plasma-workspace, but there was no change.

At the moment I can´t use an external monitor. I don´t know how to attach it.
In KDE I can´t find a monitor, even not the laptop monitor. There are no monitor settings. There is a blank space only.

Also there is no network applet among the widgets.
When I want to get additional widgets from kde, than it says: no network available.
If I want to use a network then it says: Qubes security is in danger, don´t do that.

So what can I do do get the network traffic widget?
Should I for some seconds allow network and download it and then detach network quickly?
Or are there other ways around to get the applet?

that because it missing setting, idk how to fix it (you need to install some package)