Qubes Windows Tool ISO Missing

I am fairly new to Qubes, but I have been able to get a up and running with alot of different qubes with this one exception.

Everytime I try to launch my windows VM from the dropdown menu in Qube Manager to launch the VM with Qubes Windows Tools it does not launch. So I tried launching it through the dom0 terminal with qvm-start and I get the error “losetup: /usr/lib/qubes/qubes-windows-tools.iso: failed to set up loop device: No such file or directory.”

Do I need to download the ISO, and if so where is it available for download?

I have tried “qubes-dom0-update qubes-windows-tools” and I get the same error in the dom0 terminal.

Note: Due to the security problems described in QSB-091, installation of Qubes Windows Tools is currently blocked. Instead, a text file containing a warning is displayed. Currently, it is difficult to estimate the severity of the risks posed by the sources of the Xen drivers used in QWT possibly being compromised, so it was decided not to offer direct QWT installation until this problem could be treated properly. While Windows qubes are, in Qubes, generally not regarded as being very trustworthy, a possible compromise of the Xen drivers used in Qubes Windows Tools might create a risk for Xen or dom0 and thus be dangerous for Qubes itself. If you understand this risk and are willing to take it, you can still install the previous versions of Qubes Windows Tools, using the command

sudo qubes-dom0-update qubes-windows-tools-4.1.68

for Qubes R4.1.2, or

sudo qubes-dom0-update qubes-windows-tools-4.1.69

for Qubes R4.2.0, respectively, instead of the command listed in step 1 of the installation described below. This will provide the .iso file to be presented as installation drive to the Windows qube in step 3 of the QWT installation.

If you prefer to download the corresponding .rpm files for manual QWT installation, these are still available from the repositories (version 4.1.68-1 for Qubes R4.1.2 and version 4.1.69-1 for Qubes R4.2.0).

Warning: These older versions of Qubes Windows Tools will be replaced during the next dom0 update by the current dummy version 4.1.70-1. This can be inhibited by appending the line exclude=qubes-windows-tools to the file /etc/dnf/dnf.conf in dom0. But this will also stop any further QWT updates - so be sure to remove this line when - hopefully - a new functional version 4.1.71-1 of Qubes Windows Tools will be made available!!!

Is there another way to connect a usb drive or transfer files to a Windows qube besides QWT?

You can enable Windows USB integration without QWT:

1 Like

Any idea when this will fixed. If i’m reading this correctly, it sounds like the Xen team replaced the possibly compromised drivers back on 7-14-2023.

We have removed all previous binaries from:

Index of /pvdrivers/win

A new set of drivers based on the current master branch
(9.0-unstable) and built on a trusted environment have been uploaded
on the same folder with the following hashes:

$ sha256sum xen*.tar
b089e46d52ffc64a14799c609272ccdded805c1552a88b45d95a64a27e775de7 xenbus.tar
afc6f11f9078cb457daa000b8b8d8ab69656d3950e7afbf6f40aaa5da217301a xencons.tar
7bbcedcda5e2ffa8ab32eb3d207d1c7db5b91e22926b26d75750bfadde6611f0 xenhid.tar
a8f3344e370647696e3ed39201f5c9db693aca1c093a638fde8b7a928a4416c2 xeniface.tar
560d7049f5e321545dda25c26b5f56e0975a7f62d35629f4c9a73f0fbd148cf3 xennet.tar
9cb34cd135aab045a2401098c4044c95dbd179c454718e43045e433401b8e3dd xenvbd.tar
47c1b9bc6e90e20d3f524036a3171cf7f8da1d94186febbae0d4a108db7bb3b5 xenvif.tar
09a4b108a9d3fca699c3c31aeb4836cfee2538e588462b0646dcccbde42a4263 xenvkbd.tar

What version do you want? I have 9 different versions of the tools. I downloaded them ages ago and put them into my storage for use for whatever version I wanted instead of having to always configure things again and again.

I just attach the ISO as a BOOT TO DEVICE and it generally functions properly.
Otherwise I attach it as a device on booting via the CLI which the interface is supposed to do properly, but doesn’t do that functionality for some reason.

The new binaries are not signed by Microsoft key and they require you to enable test-signing mode in Windows.
You can read more about this issue here:

You can track this issue here:


I didnt want to make a new thread about this:

How can we use Windows Machines in Qubes without W-Xen-Drivers ?

Via RDP from another qube, maybe?


You can just use them like any normal HVM:

1 Like

Thank you @adw.

1 Like

Just install the QWT and use them… Not hard…

I still use the drivers, as there is no issue with anything that I’m doing on my Windows to worry about this “vulnerabilty”.

I posted earlier that I have 9 different versions, and asked what one you wanted, but noone wants them even though they are asking about them and wanting them?