Qubes wifi crashes (Intel WiFi card)


I am a new user of Qubes and have experienced problems with Wifi connection.

I am able to establish a connection but when i launch a Vm it becomes unstable. When using the [Untrusted] domain i can navigate for 5-10 minutes before anything goes wrong then the Vm freezes and quit abruptly. The problem is more prominent in other vm like a disposable fedora-32-dvm as it takes only few seconds before the vm freezes and quit or becomes unusable. Sometimes the problem is just affecting the Vms sometimes it’s affecting the whole Qubes system and the machine reboot itself.

While the vm crashes the Wifi disconnect itself. When the system is still usable, i can try to reload the iwlmvm module manually but the same problems arises again if i try to lauch a Vm.
The same problem arises (crash/freeze then reboot) if i try to update the system when suggested by the system.

Something else happened and i don’t know if it’s the same problem but i entered qubes-hcl-report to verify if my problem had something related to VT-d/IOMMU and i got ´input-output’ error the the system abruptly rebooted.

Where i should start to diagnose this problem?


Can you say something about your setup, the templates you have tried, and the specific WiFi card you
are using.

I am using a Lenovo ThinkPad T410.

I tried Fedora 10 and Debian 32 templates.

My Wifi card is an Intel.

Added info on intel card to topic title. It’s probably a hardware issue