Qubes-vpn-support fails to install on fedora 39

Installed a fresh fedora-39 template, cloned and switched the branch of 1choices(4.2) repo and just followed the normal setup (adding vpn-handler-openvpn etc…). the setup script runs and says Done.

From what I can tell is that systemd complains:

Unit qubes-vpn-handler.service could not be found

Even tho everything in /rw/config/rc.local is correct and the service can be found under


after AppVm (openvpn) startup

My older vpn-qubes where I just replaced the template work fine (wireguard)…

What is happening ?

Add the following to /rw/config/rc.local in case selinux is to blame:

sudo setenforce 0

Also, install Qubes-vpn-support in the app qube itself, not in the template. It will be easier.

1 Like

I installed it in an AppVM

Indeed after disabeling selinux systemd finds the service but it still doesn’t work…
I did this 3 months ago and everything just worked. did something change?

sudo systemctl status qubes-vpn-handler
● qubes-vpn-handler.service - VPN Client for Qubes proxyVM
     Loaded: loaded (/usr/lib/systemd/system/qubes-vpn-handler.service; enabled; preset: disabled)
    Drop-In: /usr/lib/systemd/system/qubes-vpn-handler.service.d
     Active: activating (auto-restart) (Result: exit-code) since Sat 2024-03-30 00:04:10 CET; 3s ago
    Process: 1403 ExecStartPre=/usr/lib/qubes/qubes-vpn-setup --check-firewall (code=exited, status=0/SUCCESS)
    Process: 1410 ExecStartPre=/usr/lib/qubes/qubes-vpn-setup --pre-start (code=exited, status=0/SUCCESS)
    Process: 1416 ExecStart=/usr/lib/qubes/qubes-vpn-setup --start-exec (code=exited, status=1/FAILURE)
    Process: 1417 ExecStartPost=/usr/lib/qubes/qubes-vpn-setup --post-start (code=exited, status=0/SUCCESS)
    Process: 1426 ExecStopPost=/usr/lib/qubes/qubes-vpn-setup --post-stop (code=exited, status=0/SUCCESS)

Can you provide more details about the steps you followed and the commands you used?

Is that the full output you got from that status command?

1 Like

I ran the install script, disabled selinux and restarted a couple times and for some reason it started working…

Probably really was just selinux. I know that support for selinux was added in 4.2 but like I said this worked 3 months ago… Why is it acting up now? And why are my other VMs working???

Not sure why. It should have happened before if your qubes are based on fedora and use the 4.2 repositories. Debian doesn’t have selinux, so if your other qubes are running on it, that would explain why they are running fine.

1 Like

You are correct wanted to check if selinux is in enforcing mode and noticed that the command wasn’t found… Checked the template and it’s debian…

I was 100% convinced that my VMs used fedora…

Anyways thanks man. Really appreciate that you take your time to help noobs like me. You already helped me countless times with some posts you made here.

I am such a f idiot…

1 Like