Qubes VM Sluggish GUI Fix

Since I have plenty of ram (128GB) I thought it was weird that my VMs were kind of sluggish in terms of gui performance. I kicked up the minimum video ram to 1 GB using: “qvm-features dom0 gui-videoram-min 1024000”. This made the gui a lot smoother in VMs, but upon reboot of qubes; sys-usb, sys-net, sys-firewall and sys-whonix were having trouble putting their respective icons in the tray. sys-usb in particular was not putting the “mouse popup” on the screen after booting unless I disconnected the usb hub my mouse was connected to and then re-connecting it. I tried setting the VMs minimum ram to a level above the 1GB minimum video ram (set to 2GB initial ram size) and everything started running smooth.

If we consider formulae in


For example, if you expect to use a 1080p display and a 4k display side-by-side, that is (1920 + 3840) × 2160 × 4 / 1024 = 48600 , or slightly more than 48 MiB per qube.

on what premises you decided to give 2GB as a min?

My post was kind of confusing, to clarify:
1GB for min videoram
2GB for min VM ram.

I started to run into trouble with the 1GB min videoram setting when opening a lot of qubes, so I reduced it to 128MB. Seems to work okay with multiple qubes open so far. Maybe my GPU ram was filling up??

1 Like