`qubes-video-companion` does nothing

I’ve installed qubes-video-companion so I could share my dom0 screen. I’ve done sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing qubes-video-companion-dom0 in dom0 and sudo apt install qubes-video-companion && qubes-video-companion screenshare in my standalone debian-12 vm. I got the system popup with a choice of target domain and a tray icon stating that I’m receiving a video stream from that domain but when I try to use any screen recorder or an application that allows for screen sharing I can only record my standalone vm’s windows.

I think it’s a known issue here Notification issue of qubes-video-companion-dom0 · Issue #8457 · QubesOS/qubes-issues · GitHub .

You’ll need the workaround to comment out the line of Notify.Notification.new(app, msg, icon).show() in /usr/share/qubes-video-companion/sender/service.py in dom0, before someone fixes the actual issue.

Thank you for the reply! I’m on 4.1 and commenting out this line does not help (as I didn’t even have any error messages related to it in my case). I still cannot share any window or screen outside the vm where I run qubes-video-companion from. Here’s what I get when I run it:

  • $ qubes-video-companion screenshare
    Receiving video stream at 1366x768 30 FPS...
  • qvc.ScreenShare confirmation window pops up with source/target domain selection.
  • Qubes Video Companion tray icon pops up with a screenshare: dom0 => <my-pvh-debian-12-qube> message when I click on it.

Woah I made a mistake :stuck_out_tongue: sorry

In fact the screensharing function of qubes-video-companion works by creating a virtual webcam in the receiver domain. So you’ll need to record the camera ( like using cheese software ) to see the screen of the sender domain, instead of using a screen recorder.


3 posts were split to a new topic: Request denied when using qubes-video-companion (qvc.ScreenShare)