Qubes v4.2 - Testing deployment in a qube

I just ran the latest build from the testing repo in a qube. There was an error message, but it was non-critical. If anyone wants to keep an eye on the latest 4.2 changes, give it a try!

I’m thinking about installing 4.2, but I have a few questions:

  • Can 4.2 be installed in a production environment, or should I only use 4.2 in a test environment?
  • What changes did you notice between 4.1 and 4.2?
  • How would you rate the stability of using version 4.2? Do you use 4.2 on a daily basis?
  • Do all the functions of the device (e.g. audio, hdmi, etc.) work for you?
1 Like

v4.2 should NOT be used in a production environment.

Install the last stable version - 4.1.2.

Once that’s installed if you want a preview of the new features, you can install 4.2 inside of a qube (in v4.1) to check out the constant progress for yourself.

Have using qubes 4.2 since early. i can say its stable, more hardware support, etc. perhaps only the debian aren’t ready. but everything is good, i can guarantee that, the thing i notice is, it’s boot faster than 4.1 xD

1 Like

Just tried the latest 4.2, but it won’t permit WiFi access (permission denied). WiFi functionality appears fine as it sees networks. Just can’t write to the drive (using disposable sys-net and sudo not setup during install).

I also noticed the qubes.InputKeyboard file automatically connects a USB keyboard, so I checked my other computer with 4.1 and it is setup the same as well (neither computer use a USB keyboard).

I do like the new look for 4.2.

1 Like

what you mean by wifi access won’t permit in sys-net disp vm ? i use sys-net sys-mirage sys-vpn on disp vm, everything is good.

I keep trying to download the latest weekly build from here:
but the download keeps failing. Do I have the right link?

It works for me, but I didn’t try to download the full ISO. On what stage is it failing? Maybe it’s because of a bad network connection on your side (if you’re using Tor for example)?

Oh, I’m sorry. The download was failing because my appvm was running out of disk space. I have the ISO now. I’ll report back once I try it. Thanks.

When I select a network to connect, any network, it shows an error that it tried to make a file (including the network name), but permission denied. Never get a chance to logon. This is with the most recent ISO.

I plan to try R4.2 again, so if it happens on a later build I’ll write down the precise error and file name path. And post.

Maybe it’s a new bug, I’ve tested older build Qubes-4.2.202304291601-x86_64.iso and I could connect without problem.
I guess that it can’t write a NetworkManager config in /rw/config/NM-system-connections/<connection name>.nmconnection for some reason.

Yes! That was it.

i have an up to date qubes 4.2. now using kernel 6.3 still haven’t a problem with it, perhaps because of the template ? i use fedora on all vm

1 Like

Wifi works out of the box now which is an improvement, but my touchpad doesn’t work any more. It worked on the stable release. I have to use a USB mouse now.

Did you use particular settings to let 4.2 run ? What can you test inside, only dom0 ?
Can you run PV, PVH, HVM qubes ? Is the network working ?

Yea, only test dom0 and get the networking online.

Theoretically if you have enough ram then you may be able to run a VM inside of another VM, but from a security standpoint this may not be ideal.

I used 30GB of hard drive, 8GB of ram, and bumped the virtual CPUs to 4 (even though this may not make a difference)