[qubes-users] Xfburn not seeing usb

Trying to create a bootable usb, installed Xfburn and connected the usb to the AppVM but when I open Xfburn as root it doesn’t see the usb and says:

“no burners currently available, possibly the discs are in use and cannot get accessed”

Also tried installing Brasero which won’t burn to usb

You may need to run the software in the VM which contains the physical hardware (e.g. the USB controller}. Passing a memory device generally works but when you need special access to the physical hardware such as burning a DVD then this pass-through method may not work correctly.

If your USB controller is in sys-usb then running Xfburn or Brasero there is the best option. If not, and you have several USB controllers, you might want to investigate creating a sys-usb for that purpose. Otherwise then you may need to decide if you want to install a DvD burning package directly in dom0, which generally should be avoided if possible.


I installed gnome-disk-utility and it sees the usb so I was able to format it, but when I try to flash it the .iso I downloaded is grayed out. Any way to make that accessible?

I don’t have a sys-usb, just sys-net and sys-firewall. I tried running sudo qubesctl state.sls qvm.sys-usb but it didn’t work, output says something like:

the following requisites were not found:
sls: qvm.sys-net