[qubes-users] Wifi and Bluetooth not working on Qubes release 4.1.2 | Kernel version like 5.15.xx

Hi Team,

I am facing an issue with “Qubes release 4.1.2”.

Its like I am not able to connect to Wifi (no Wifi connection option available).
Also, not able to see any bluetooth option.

For wifi, I was able to see below error in sys-net qube:-

so I tried to install linux-firmware and backport-iwlwifi as per the first answer here, and as I am newbie to Linux, so I tried to follow steps for installation of backport-iwlwifi as per this, but no luck.

I tried to install these above two firmwares on sys-net qube, which didn’t make any impact, later I performed these 2 firmware installation on debian 11 template qube, and after this, sys-net qube started throwing this error and didn’t start:-

I remember the kernel version was something like 5.15.xx on my machine.

My PC configuration is like as follows:-

CPU: Intel i5 13600K
Motherboard: ASUS TUF Gaming Z790 PLUS WIFI
RAM: 32 GB

Please suggest what should I do? Should I wait for Qubes 4.2 release or some other fix can be applied manually at my end ?

Thanks and Regards

Hi Team,

Here is an update:-

I installed “Qubes release 4.2.0-rc4” and verified that

  1. Wifi and wired connections
  2. Sound

both are working in this test-release.

For bluetooth, I am still troubleshooting, will let you know once I find any fix.

In meanwhile, if you already are aware of fix of bluetooth issue, please share that with me.

Thanks and Regards

1 Like