[qubes-users] VT-d on XPS 9310

Hello all,

My problem is quite simple: I tried to install qubes 4.0.4-rc2. During the installation procedure, it says that I don’t have IOMMU/VT-d. Accordingly, I cannot even start sys-net once the installation completes because of lack of VT-d.

The problem is that my computer supports VT-d (CPU is intel i7 1165G7). VT-d is moreover enabled in my bios. Any clue about what the problem could be?


Maybe dom0 'dmesg' and 'xml dmesg' help. Also try to upgrade your BIOS.

Wops, I meant 'xl dmesg'.

Probably a dumb question, but is VT-x also enabled?

Ok, I found something: Running xl dmesg there’s a line that says:

(XEN) Failed to parse ACPI DMAR. Disabling VT-d.

The output of dmesg looks very technical and is unreadable to me if I don’t know what I’m looking for.

…I guess VT-x is enabled as well. In bios I have only the options to enable VT and VT-d. I guess the former refers to VT-x?


I only think to try updating BIOS or using Qubes R4.1 which has newer
Xen version (although is pretty unstable yet). It will help to know if a
newer Xen version runs ok.


Ok, my BIOS wasn’t updated. That solved the VT-d problem.

Everything seems to work aside of wifi. I have a Killer AX500, which is currently supported only in kernel 5.10+. For what I understand, in Qubes Fedora comes with Kernel 5.4.something at the moment. I’ve found some tutorials to update a generic Fedora kernel to 5.10, but I suppose the kernel I’m running now is customized to be ran within a qubes environment. If I try to compile and update sys-net to kernel 5.10 how likely it is that I’ll make a mess?



Take a look in Managing VM kernel | Qubes OS
specially in 'Using kernel installed in the VM' section. Last time I've
tried it with Centos template it failed and finally I installed a HVM,
(could work using a HVM as sys-net?).