[qubes-users] Tried to install google earth pro to debian qube, need help understanding error message

I bolded the relevant terminal text
N: Download is performed unsandboxed as root as file ‘/home/user/Downloads/google-earth-pro-stable_current_amd64.deb’ couldn’t be accessed by user ‘_apt’. - pkgAcquire::Run (13: Permission denied)

What does this mean? Did the program fail to install? Do I need to install it to my template VM? What should I do? FYI: I’ve done my best to install everything to the OSINT qube alone but idk if this particular install got through.

user@OSINT-template-debian:~/Downloads$ sudo apt install -y ./google-earth-pro-stable_current_amd64.deb
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘google-earth-pro-stable’ instead of ‘./google-earth-pro-stable_current_amd64.deb’
The following packages were automatically installed and are no longer required:
python-numpy python-olefile python-pil python-pkg-resources
Use ‘sudo apt autoremove’ to remove them.
The following additional packages will be installed:
The following NEW packages will be installed:
google-earth-pro-stable libglu1-mesa
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 169 kB/56.2 MB of archives.
After this operation, 250 MB of additional disk space will be used.
Get:1 https://deb.debian.org/debian buster/main amd64 libglu1-mesa amd64 9.0.0-2.1+b3 [169 kB]
Get:2 /home/user/Downloads/google-earth-pro-stable_current_amd64.deb google-earth-pro-stable amd64 [56.1 MB]
Fetched 169 kB in 1s (236 kB/s)
Selecting previously unselected package libglu1-mesa:amd64.
(Reading database … 134496 files and directories currently installed.)
Preparing to unpack …/libglu1-mesa_9.0.0-2.1+b3_amd64.deb …
Unpacking libglu1-mesa:amd64 (9.0.0-2.1+b3) …
Selecting previously unselected package google-earth-pro-stable.
Preparing to unpack …/google-earth-pro-stable_current_amd64.deb …
Unpacking google-earth-pro-stable ( …
Setting up libglu1-mesa:amd64 (9.0.0-2.1+b3) …
Setting up google-earth-pro-stable ( …
xdg-desktop-menu: No writable system menu directory found.
Processing triggers for mime-support (3.62) …
Processing triggers for libc-bin (2.28-10) …
Processing triggers for man-db (2.8.5-2) …
Processing triggers for qubes-core-agent (4.0.61-1+deb10u1) …
Processing triggers for desktop-file-utils (0.23-4) …
N: Download is performed unsandboxed as root as file ‘/home/user/Downloads/google-earth-pro-stable_current_amd64.deb’ couldn’t be accessed by user ‘_apt’. - pkgAcquire::Run (13: Permission denied)

if you want to split download & install, run apt-get download as USER
not as root. Then, later, install with apt -i ./my-unsage-deb-file.deb
Do such things better in a separate VM :slight_smile:

Thank you for your reply. I’m rather inexperienced with Linux and these sorts of issues. Could you give me the format of the command I need to input? Also, I did not download google earth pro with apt at all, instead, I downloaded it manually off the website and then tried to install it. Does that affect your advice at all? Thank you and be well.

you can install any .deb file like that. Download whatever (zoom,
google-earth..) deb file in your unsafe VM, then open terminal and launch

sudo apt install some-path/filename.deb (*)

(don't copy (*)). Technically you can do this in a templateVM (with some
extra complications since no netVM in templates), but unless you use the
software every day & reboot often that is not my favourite solution.
Instead, I run it *once* in the AppVM: now, often apt needs to install
dependencies along with it. Copy the list of needed packages (or write
them down) and install all of them with

apt-get install PACKAGE

in your templateVM. These library files are clean and safe (a priori).
Now, once you reboot your AppVM the App is gone, but re-installing it
with the command (*) takes 15 secs and you data (logins, config files)
will survive from one install to the next.

Advantage of this procedure: no template is possibly breached with the
unsafe .deb file. Disadvantage: you loose 15 secs at every reboot of the
AppVM for reinstalling. For me its worth the pain.