[qubes-users] Still Seeking Help with PCI & Other Devices

I am still not having any luck using PCI devices, PCI passthrough, qvm-pci command, or use with xl. Devices tab is greyed out in vm settings windows.

qvm-pci returns: Failed to list 'pci' devices, this device type either does not exist or you do not have access to it.

lspci returns the devices with ID like: 0000:01:00.1

In dmesg I see it load my PCI devices.

The device id like to use is a GPU, it is recognized and has nouveau module loaded in Dom0.

When I try ~sudo xl pci-attach personal 0000:01:00.0, the response is:

libxl: error: libxl_pci.c:1634:libxl__device_pci_add: Domain 6:PCI device 0:1:0.0 is not addignable
libxl: error: libxl_pci.c:1774:device_pci_add_done: Domain 6:libxl__device_pci_add failed for PCI device 0:1:0.0 (rc-3)
libxl: error: libxl_device.c.1450:device:addrm:aocomplete: unable to add device

I see for one person they had to disable Intel Volume Management in Bios-
I tried this, but this option is not in my bios. I also tried disabling USB Virt and other Intel security utils with no success.

If I do ~ sudo xl pci-assignable-list, it returns nothing.

I also tried adding, per the xen wiki, to Grub (no changes):
xen-pciback-passthrough=1 xen-pciback.permissive

~xl info | grep caps
hw_caps : ~~somehash
virt_caps : pv hvm hvm_directio pv_directio hap iommu_hap_pt_share
xen_caps : xen-3.0 hvm~~x86_64/32/32p

This is the thread that seems like my error, but I still have not found a solution after exploring this many times over: Devices greyed out - qvm-pci gives "failed" - #4 by zithro

PC: Alienware X17 R2 EUFI w/ Nvidia 3080, Thunderbolt etc..
I've tried disabling just about everything in bios including the usb virtualization with no changes yet.

Currently I can only attach USB devices. That is to any VM - all vm settings have devices greyed out.

Any suggestions will be GREATLY appreciated!!!