[qubes-users] Skype audio working

After much trying my skype audio on a lenove x230 now works.

Problem was a strange setting in System tools/Volume control/Input devices

Default setting is “Internal Microphone” which seemed correct because I was really trying to use the microphone incorporated inside the notebook, but it is not correct.

Correct setting is “microphone” not “Internal microphone”.

The setting “microphone” works well not only with the internal microphone, but also if an external microphone is plugged into the notebook.

it is even not required to restart skype after any change.

However this setting change does not survive reboot. After reboot the default setting is again the non working “internal microphone”. Tried to google how to change default settings of pavucontrol, but it seems it does not has default setting, rather a fallback to what worked last time with that particular audio program or skype in my case. Why it does not really remember what worked? Maybe that Qubes separation between Domo, where pavucontrol resides, and the VM, where the audio program runs, cuts some connections critical for pavucontrol to remember?

Also it may be only a problem of Lenovo x230 (tried on 2 different x230 with identical results). On Qubes lists there were people able to use skype without this issue. So it may be that with other computers pulse audio automatically gets the right microphone.

Well changing microphone setting after every reboot is not much work, if you know what you have to do. Problem is for people that do not know what to do.

Still it seems I have bad luck also for video. The webcam is on Bus 1, but on Bus 1 there is also the Bluetooth device. Alarm! If I assign the webcam to the relevant VM I’ll assign also the Bluetooth which is strongly discouraged by Joanna.

It seems the only way to assign the webcam to a VM is opening the laptop to follow this tutorial to remove the bluetooth daughter card: http://support.lenovo.com/en_US/product-and-parts/detail.page?&DocID=PD024304



Oh, that seems like a good thing to do anyway :slight_smile: Who needs BT, really?