[qubes-users] Qubes USB Install Issues

I've been trying to install Qubes-os from a ~16GB USB stick for a few days now and it seems no matter what i do, i dont seem to be able to install from USB using any of the Qubes images...and yes i've tried what http://wiki.qubes-os.org/trac/wiki/UsbInstallation says (which didnt even seem correct to me to begin with).

I've tried doing what the wiki says, using RUFUS, and even just extracting the .iso into the usb stick. None of it worked. Previously, i've used T(A)ILS, openSUSE live, and even installed windows from the same USB stick so i am fairly certain i know what to do but i've had no luck with installing Qubes from a USB stick, which is my only available option.

Anyone have any suggestions? I am running Windows 7.

For me it works perfectly. Perhaps you used something wrong in the place of

Here are the steps I took. Maybe it can help you. I used linux though.

Boot your linux distro
plug your usb stick
go to a terminal and type: "dmesg" (check on the last lines if it has sucessfully connected and check the name its got (for example, /dev/sdb)
you can check that with "fdisk -l" too
type cfdisk /dev/sdb (if it was "b")
and erase all partitions (it will be only one line saying FREE SPACE)
press Write
then "dd" the iso to the usb stick typing: "dd if=/path/to/your/iso of=/dev/sdb" This might take several minutes to complete.
then reboot your system when its completed.
Press f8 or f11 (depending on your BIOS to go to the boot menu) and select your usb to boot from.
Then hopefully you will meet the Qubes installation screen.