[qubes-users] Qubes 4.2 installation problems due to Salt alone - what to do?

Dear Qubes Community,

I am trying to install Qubes 4.2. in vain, not because the hardware is incompatible, but because of Salt problems. I verified the downloaded ISO according to the instructions, burned the ISO with various programs on a USB stick, among others with the DD command:

dd if="./Qubes-R4.2.1-x86_64.iso" of="/dev/sda" status="progress" conv="fsync"

I have checked the result and it shows that the hash sum of the USB stick under /dev/sda is the same as the downloaded file:

sudo dd if=/dev/sda bs=1M count=$(stat -c %s /home/user/QubesIncoming/XXX/Qubes-R4.2.1-x86_64.iso) iflag=count_bytes | sha256sum

When I start the computer with the USB stick and test the medium, the following appears first:

Fragment sums: 2695f8d1(...)
supported iso: no

Then, when the test has run 100 percent, the following appears:


If I install anyway, I have to cancel the automatic creation of sys-net, sys-usb and personal AppVMs, because otherwise I get an installation error because the installer does not set the PCI devices to disable strict reset. At the end of the setup it still says:

"initial config failed", see /var/log/salt/minion

The log there says:

Specified ext_pillar interface qvm_prefs unavailable

And when I try to update dom0, it fails. The reason is noted in the same log file:

Unable to detect release version
Cannot prepare internal mirror list: SSL peer certificate or SSH remote key was not OK for https://mirrors.fedora(...)

Everything otherwise works according to the HCL report, including Suspend, Ethernet, USB, Speaker. Strange thing was that no default-mgmt-dvm seemed to be present and was not started during update attempts.

I have already tried the installation with 4.2.0 and 4.2.1, with standard kernel and with the latest kernel.

How could I solve the problem?

Thank you,
Michael Singer

Hmm, You might find it more useful to join the Qubes Forum,


I wanted to reply, so you felt someone will help.

Perhaps Clarify some things.

Seems from your discussion of SALT, you know something of Linux.

If the standard install did not finish correctly. I am not thinking whatever is going on with SALT is the problem. But SALT commands might reveal to some what is happening?

So, for me in your situation, I would go through the detail of what I assumed was true, but might not be.

Can you clarify.
Why are you sure the computer in question is compaitble with Qubes? Have you used Qubes on it before?

Did you install UEFI or Legacy? I use Legacy, UEFI is a different set of problems.

Does your computer have one or two drives? (I have one computer, with two drives, that will only let me install Qubes to one drive, and the other drive must not have anything on it. Other computers don’t care. and I did not say it made sense)

Are you trying to accomplish a dual boot? (Qubes wants to be alone on the drive. Some folks have gotten dual boot to work. I have not tried)

Did you try to install Qubes on a drive that already had -----something? (I have discovered that sometimes Qubes does not like to installed over something else. Sometimes does not care.)

Can you devote this computer to using Qubes right now? Or is it a computer you use daily with another OS?
(helps to limit suggestions to something that is more reasonable for you to try)

I think someone more knowledgeable than myself will come by and recognize your symptoms, and you don’t have to worry about answering this. But it can’t hurt.

In a coupla days, If you have not gotten it going, I will come back and add more suggetions. More confusion.

but someone might recognize symptoms and make an easier fix.


Thank you! The hardware clock had the wrong date. Therefore the error with salt.