[qubes-users] Qubes 4.2: Attach usb audio device to appvm

After upgrading to 4.2 my audio device does not work.

I plug in a usb audio device, then attach that usb device to an appvm and try to use it in e.g. meet.google.com.
For some reason it only works for the audio microphone or the speaker, not both.

  1. I attach the usb device to the appvm.
  2. meet.google.com automatically switches to the new microphone, but I cannot hear anything and the speaker list does not show the usb device.
  3. I then detach from the appvm and reattach the usb device to the same appvm.
  4. meet.google.com does not show the usb device in the list of microphones. but somehow the “default” speaker now outputs through the usb device.

In 4.1 it would either work for both mic and speaker or for none.

1 Like

Now it is more consistent in how it is not working.
Audio output is connected properly.
But microphone is still not working. It does not capture any sound from the microphone, but it does repeat a ticking sound. I have attached a 3 second recording of the ticking sound.

I have not changed any audio settings.
I have tested with two different usb soundcards.
It worked in Qubes 4.1.

I wonder what has changed in the audio setup from Qubes 4.1 to 4.2.

(Attachment test-mic2.wav is missing)

Installing a new template fixed it.
I installed fedora-39 and switched to it.

The old template had been upgraded in-place several times, back from fedora-36, I think.
Maybe something is missing in the upgrade from 4.1 to 4.2, or in the instructions on how to upgrade existing templates to 4.2.

It was not fixed…
Apparently just an example of how random it is.
It was working for an hour or so. Now it is back to mic not working, just sending out that beep beep sound.