[qubes-users] Qubes 4.1: How to set private storage max size using SALT?


Please see subject line :wink:

Thanks for any pointers.


You have to include a call to qvm-volume in your state file.

'qvm-volume extend QUBE:private 50G':

Super! Thank you!

Turns out, this does not generally work. The first time the command runs (and <REVISION>, the target storage size is really bigger than what is set) everything is fine, but as the shorthands like `G` do not reflect what's really set (in bytes) under the hood such a statement fails on every further run, as `qvm-volume` returns an error: `For your own safety, shrinking of private is disabled ...`

For me this works: set size manually for one VM, check the "real" byte level size using `qvm-volume i QUBE:private` and use the "real" full number rather than the `G`-shorthand ... inconvenient. If `qvm-volume` allows to set using shorthands, it also should take care of using that info when checking.