[qubes-users] Install Nvidia driver in Dom0


this is my first mail to this mailing list. So first I want to thank everyone involved in developing Qubes. It's a great concept and every OS should offer it as an option, we'll see if it gets adopted from others...

I want to use Qubes as my primary desktop OS and I don't want to multiboot so I have to get the Nvidia driver installed.
I've installed Qubes R2 Beta 2 so I'm not sure if one of the methods described on http://qubes-os.org/trac/wiki/InstallNvidiaDriver works here (last modified 14 month ago...).

Perhaps I should use R1 to make Nvidia work? R1 uses Fedora 17 if I see that correct. Fedoras package database doesn't show the 17 release so this would mean that there are outdated packages and no security fixes anymore?

I tried both, the RpmFusion method (in an AppVM) and the manual method (in Dom0, except downloading).

I did
yumdownloader --resolve xorg-x11-drv-nvidia livna-config-display
yumdownloader --source nvidia-kmod
yum install rpm-build
rpmbuild --rebuild nvidia-kmod-319.32-2.fc18.3.src.rpm (differs from user guide but that's what was downloaded by yumdownloader --source nvidia-kmod)

last step got me:
error: Failed build dependencies:
  /usr/bin/kmodtool is needed by nvidia-kmod-1:319.32-2.fc18.3.x86_64
  buildsys-build-rpmfusion-kerneldevpkgs-newest-x86_64 is needed by nvidia-kmod-1:319.32-2.fc18.3.x86_64

Installing kmodtool worked but I get that error installing buildsys-build-rpmfusion-kerneldevpkgs-newest-x86_64:
Error: Package: 10:buildsys-build-rpmfusion-kerneldevpkgs-current-18-40.x86_64 (rpmfusion-free-updates)
           Requires: kernel-devel-uname-r = 3.10.9-100.fc18.x86_64
           Available: kernel-debug-devel-3.6.10-4.fc18.x86_64 (fedora)
               kernel-devel-uname-r = 3.6.10-4.fc18.x86_64.debug
           Available: kernel-debug-devel-3.10.10-100.fc18.x86_64 (updates)
               kernel-devel-uname-r = 3.10.10-100.fc18.x86_64.debug
           Available: kernel-devel-3.6.10-4.fc18.x86_64 (fedora)
               kernel-devel-uname-r = 3.6.10-4.fc18.x86_64
           Available: kernel-devel-3.10.10-100.fc18.x86_64 (updates)
               kernel-devel-uname-r = 3.10.10-100.fc18.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

I downloaded NVIDIA-Linux-x86_64-319.49.run moved it to Dom0 and did:
./NVIDIA-Linux-x86_64-319.49.run --ui=none --no-x-check --keep --no-nouveau-check --no-kernel-module

then I installed kernel-devel and gcc.
And checked the directories (they of course differ from guide):
    /lib/modules/3.7.6-2.pvops.qubes.x86_64/build symlinked to the above directory
    /usr/src/kernels/3.7.6-2.pvops.qubes.x86_64/arch/x64/include/mach-xen should be present (if not - take it from kernel sources)

Last one isn't there (/usr/src/kernels/3.7.6-2.pvops.qubes.x86_64/arch/x64/include/mach-xen) and the guide tells me to take it from the kernel sources. Don't know where to take it from because this are the sources and it tells me to take it from the sources but it isn't in the sources...

Thanks in advance

The short answer - Nvidia does no longer support running its binary drivers on
Xen. Actually it never was supported, but some time ago it accidentally
worked. Now it doesn't.
What is wrong with open source driver (nouveau), which is installed by default
with Qubes?