[qubes-users] HCL - Dell_Inc_-XPS_17_9700

4.0.4 or 4.0.4rc1 would not install (tried all the workarounds). 4.1 alpha installed no problems, no special boot options it just worked.

Upgraded to kernel latest, which fixed bluetooth and some performance. Needed to give sys-usb more RAM to function properly (otherwise keyboard/mouse would lag when started usb network).

I built a custom kernel for latest intel sound drivers and Qualcomm wifi6 (linux-kernel.patch attached).

Everything except wifi works.
Touchscreen sort of works (acts like a tablet input)

Bluetooth works.

Audio works (with kernel 5.10 and attached kernel base-config patch + latest 1.6.1 sof-bin firmware https://github.com/thesofproject/sof-bin and alsa-ucm-config files. see https://blog.fts.scot/2020/07/04/dell-xps-2020-how-to-get-audio-working-on-linux/ for alsa ucm config ).

Does not work:
Qualcomm AX500 wifi. I have the latest firmware and it works fine on bare metal fedora 33. However, with Qubes, the xen pci passthrough is not working. Here is the error from the sys-net qube dmesg:

[ 5.706045] ath11k_pci 0000:00:06.0: WARNING: ath11k PCI support is experimental!
[ 5.706448] ath11k_pci 0000:00:06.0: BAR 0: assigned [mem 0xf2000000-0xf20fffff 64bit]
[ 5.734248] ath11k_pci 0000:00:06.0: failed to get 32 MSI vectors, only -28 available
[ 5.734289] ath11k_pci 0000:00:06.0: failed to enable msi: -28
[ 5.736589] ath11k_pci: probe of 0000:00:06.0 failed with error -28
I have tried permissive, no reset etc. I even tried the latest ath11k driver from the 5.11 kernel but no luck getting it to work with xen pci passthrough.

There is a TPM 2.0 module which the kernel appears to see but HCL report doesn’t?

Qubes-HCL-Dell_Inc_-XPS_17_9700-20210109-183429.yml (858 Bytes)

(Attachment linx-kernel.patch is missing)

Hello, I have an XPS9310 and I’m in a very similar situation with AX500. Any news there?

Also, audio does not work. I’m running qubes 4.0.4 and It used to work until I upgraded to kernel 5.10.13-1. I have absolutely no experience with kernel building, any possible further detail you could share about what you did to make audio work would be super appreciated!