[qubes-users] HCL -ASRock B560 Pro (NIC Intel I219-V unrecognised)

Machine purpose built to run Qubes
ASRock-B560Pro, Intel i5-11500
500G NVMe x4, 16G RAM (might have needed more RAM)
so onboard graphics, NIC, single PS/2 port, planned to use splitter for key/mouse, dual PS/2 only present too old tech

annoying problem with display resolution stated at 800x600, actually appears as normal HD but top bar pushes Apply Cancel buttons off bottom of screen in Qubes Settings, nigh impossible to click buttons while chasing settings (took a while to realise there was buttons off-screen!)

The real problem!
No recognition of Intel i219-v NIC
Likely due to lack of recognition;
"Unable to reset PCI device... no FLR PM reset etc..." selected in the exceptions which allowed sys-net to start
Altered sys-net from fedora-32 to debian-10 =same problem

tested fedora-34 live CD on bare machine, works perfectly
likewise worked with bare metal garuda OS
but not with linuxmint 20.1 =same problem with nic

attempted via long process get files onto a VM, to install fed-34 as HVM, which failed at 4%
gave up on installing other HVM's no exFAT support, no net to install exFAT support

looks like a kernel problem? I don't know enough...

via usb phone tether updated entire qubes (dom0, fed32)
installed fedora-33 from repository
same problem, 20+hrs wasted, can't afford to continue flogging a dead horse

there are no older kernels to test in a fresh install,
there appears to be one other in repository, but still recent, the NIC is year's old apparently...
conclusion, so much for hardware requirements,
Intel integrated graphics, VT-d, even IO-SRV not that there's a graphics card

Anyone with a single combo PS/2 port, (recent boards no longer have dual) this board had a dual PS/2 via splitter option in UEFI,
but Qubes allowed installation of sys-usb with PS/2 keyboard only attached, then worked with a USB mouse attached afterwards for multiple boots.
I didn't get as far as buying a splitter cable, and there's wiring diagrams about.

Qubes-HCL-ASRock-B560_Pro4-20210525-105137.yml (719 Bytes)

(Attachment Qubes-HCL-ASRock-B560_Pro4-20210525-105137.cpio.gz is missing)

Have you tried PCI Devices | Qubes OS ?

If not, maybe I hold off adding your HCL to the next pull request until you had a chance to try? Let me know.


That NIC shows up in 35 positive HCLs ... just checked.


Thank you for your HCL report, which is now part of this pull request:

... and will be visible on the website soon!