[qubes-users] HCL - <Acer Aspire V3-371 >

Hi I’m here to report how Qubes works on my 6-year-old laptop after 1-month of installation. In short, it can take longer time to start-up VMs (inevitable for my 8Gb RAM), but once a VM is on, softwares within it run smoothly. I once received a warning like “not enough memory to start a new VM”, but that was when I had 6 other VMs running.

Pre-installation check:

This model has Intel VT-d available (checked on intel official specs: https://ark.intel.com/content/www/us/en/ark/products/85212/intel-core-i5-5200u-processor-3m-cache-up-to-2-70-ghz.html).

But I wanted to make sure if it was on, as this aspect is not visible on the very restricted factory BIOS. I downloaded the Intel Processor Identification Utility to scan my hardware, and it appears that Intel VT-d is turned off.

I could not find a way to turn this feature on without replacing my BIOS, so I figured I’d try the installation anyway.

I installed Qubes-R4.0.4-x86_64 through a bootable USB made with Rufus on Windows 10.

Booting with UEFI: (didn’t work for me)

I chose to wipe the disk and did a full install. It all went fine and it said “Installation complete”. But then I was unable to boot into Qubes. My BIOS(?) thought its windows OS is corrupted and offered to reinstall/ repair windows, and both options returned error.

Booting with legacy: (worked)

I then force-close the laptop and try install Qubes in legacy mode, and it went smoothly. Did not meet error with Intel VT-d feature.

Qubes management:

I chose to install the additional Debian TemplateVM, sys-net, sys-firewall, sys-whonix. They all worked fine. I was unable to update TemplateVMs with the GUI Qubes updater, but with command prompts it worked fine.

Other functionalities:

  1. wifi connection: OK

-a minor bug: when I wake laptop from sleep and wifi network reconnects, system message displayed “Network disconnected”, even though I was connected to the wifi)

  • the time display wasn’t accurate at first, but once I got the system on the internet it synchronised automatically
  1. i-bus Pinyin input: OK (I installed on TemplateVMs, so when I turned on both fedora and debian VMs, there’re two input method icons displayed)

  2. fn keyboard shortcuts: OK

  • no problem to adjust volumn, screen brightness and logout/hibernate options with original keyboard shortcuts
  1. USB ports: partial OK
  • USB 2.0 port, but not USB 3.0 port is usable. The USB 2.0 can be isolated in a VM and then attach to another workspace VM (e.g. personal)
  1. Software installation: OK

Apart from command prompts, I used Synaptic Package manager for Debian and Software Manager that comes with Fedora. Both worked fine.

And yeah, that’s all. I am practically a newbie in Linux and there were other bloopers when I tried install Qubes, but the detailed documentation solved most of my problems. Thanks for the teams great work!

Qubes-HCL-Acer-Aspire_V3_371.yml (925 Bytes)

Hi celiashc,

thank you for your HCL report, which is now part of this pull request:

It will be visible on the website soon!