[qubes-users] dom0 update broken after upgrade to 4.1

Hello list,

after upgrading from 4.0.4 to 4.1 my dom0 update seems broken:

$ sudo qubesctl update.qubes-dom0
[ERROR ] Failed to import module localemod, this is due most likely to a syntax error:
Traceback (most recent call last):
File "/usr/lib/python3.8/site-packages/salt/loader.py", line 1685, in _load_module
mod = spec.loader.load_module()
File "<frozen importlib._bootstrap_external>", line 522, in _check_name_wrapper
File "<frozen importlib._bootstrap_external>", line 1027, in load_module
File "<frozen importlib._bootstrap_external>", line 852, in load_module
File "<frozen importlib._bootstrap>", line 265, in _load_module_shim
File "<frozen importlib._bootstrap>", line 702, in _load
File "<frozen importlib._bootstrap>", line 671, in _load_unlocked
File "<frozen importlib._bootstrap_external>", line 848, in exec_module
File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
File "/var/cache/salt/minion/extmods/modules/localemod.py", line 222, in <module>
@decorators.which('locale-gen')
AttributeError: module 'salt.utils.decorators' has no attribute 'which'
'update.qubes-dom0' is not available.
DOM0 configuration failed, not continuing

I also found [ERROR ] Failed to import module localemod which seems to be the exact same error.

On another note: I tried to install the new gentoo template by issuing `sudo qubes-dom0-update --enablerepo=qubes-templates-community qubes-template-gentoo`,
which results in `qvm-template: error: template 'gentoo' not found.` Could this be related, maybe because dom0 repo cache cannot be updated because of the error mentioned above?

Kind regards

tracked here: upgrade from 4.0 to 4.1 breaks dom0 update -- [ERROR ] Failed to import module localemod · Issue #7114 · QubesOS/qubes-issues · GitHub

no solution I've seen yet. (I'm also affected)