[qubes-users] Backup to SMB mounted NAS in AppVM

Last night I tried to run QubesBackup, selecting an AppVM as the target, and then selecting the SMB-mounted (r/w) folder.

The backup process started, and the progress bar presented a small sliver of blue on the left, but was 0%. Nothing was ever written to the target. No errors were ever suggested by the backup process. Pretty much 0% CPU was being used in dom0.

After several hours, I closed the dom0 QubesManager window, which also closed the backup window, and tried re-running it directly as “Qubes Backup” from the menu. It claimed I had a backup running. Still nothing whatsoever written to SMB mounted folder.

Has anyone successfully written to SMB mounted share using backup?

Just retried my backup, this time using a 1T SSD USB, formatted ext4, mounted in the same AppVM.
This time, it successfully created the backup file, but it remains at zero length and dom0 remains pretty much idle.

Is backup broken?

I’m on 4.0 per the recent 4.0.4 install plus any/all intervening updates.

While typing this and poking about getting the screen shot appended, still zero bytes written to the destination.
The target AppVM is running qrexec casually. dom0 is running casually, but mainly running the top and xl top and display.

OK! There is a bug in the backup programme. I observed that there was an scrypt process just wedged. Not doing anything.
A brief moment of reflection as to why that might occur and I realised that my recent selection of a spiffy new password was the problem.
My spiffy new password had a ‘!’ character in it. Aborting the hung backup, excising the ‘!’ from the password, all other being the same, and now my backup is screaming along at the usual torpid pace.

Could be a password length bug, not a contents bug, as removing the ‘!’ shortened the password by one.

Too bad the backup can’t run multiple scrypt in parallel. The backup could be torrid, rather than torpid.