[qubes-users] 4.1 rc1 'start automatically on boot' saving abnormality

Note: Made a Tasket Qubes vpn support networking qube on Qubes 4.1 rc1 which works efficiently as always but when I check the ‘start qube automatically on boot’ box in Qube Settings / manager gui it won’t save if I click on ‘apply’ first.
But it will save if I just check the box then click directly on ‘OK’.

Can you provide exact steps you've done? Which buttons and in which
order you clicked? I just tried and clicking 'apply' just after
selecting 'start qube automatically on boot' does save the setting for

What qubes-manager package version you have, you can check it with
`rpm -q qubes-manager` command.

- --
Best Regards,
Marek Marczykowski-Górecki
Invisible Things Lab


Qubes manager version: qubes-manager-4.1.19-1.fc32.noarch .

Start qube automatically on boot:

On a normal default app qube based on a template, either fedora or debian, either running or not running.


  1. Highlight the qube I want to get to open automatically on boot in the Qubes manager.
  2. Click on the ‘Qube Settings’ cog button and the manager opens to the ‘Basic’ page.
  3. Click to check the ‘start qube automatically on boot’ box, the check mark appears.
  4. Click on ‘Apply’. The system working icon appears, the change looks to be working but then the check mark disappears.
  5. Click on ‘OK’ and the manager window closes, the desired change has not happened.

However if I click on just the ‘OK’ button the change is saved correctly.

Or, if I don’t give up so easily and try checking the ‘start qube automatically on boot’ again, then clicking ‘Apply’ again, then ‘OK’, the change is saved.

I have done this many times in writing this and the behaviour seems to continue with the ‘start qube automatically on boot’, action. However the same thing was happening with saving a networking selection but that has mostly corrected itself:


The networking selection - as above but changing a qube’s networking choice, from, eg. ‘sys-vpn’ to ‘firewall’ - was doing the same behaviour as above.
But now it looks like the action will not be saved - I make a selection, the ‘networking’ menu shows the ‘sys-vpn (current)’, option.
I choose ‘firewall’, and click ‘Apply’.
The ‘system-working’ icon appears.
The ‘system-working’ icon disappears and the selection I made - ‘firewall’, reverts to ‘sys-vpn’. So it appears my action failed.

But when I click, ‘OK’, the change has successfully happened.

Thank you, and I’m loving 4.1.

Ok, this is the crucial step: it indeed happens when qube settings is
opened from within qube manager. When it's opened from the menu
separately, it works fine.

I've copied your report to Qube settings revert back after clicking "apply" · Issue #7039 · QubesOS/qubes-issues · GitHub

- --
Best Regards,
Marek Marczykowski-Górecki
Invisible Things Lab

Oh, it's even funnier than that. Clicking apply several times will
toggle the setting each time!

- --
Best Regards,
Marek Marczykowski-Górecki
Invisible Things Lab