Qubes Upgrade to 4.2 - In Place Upgrade

You can install Qubes OS in a VM and check how default configs looks like.

I wonder if somebody would paste the contents of their sys-usb config files.

how to check if qubes-input-proxy package is installed in the sys-usb VM?

dpkg -l | grep qubes-input-proxy-sender

which is the most current version?

[workstation user ~]% apt info qubes-input-proxy-sender
Package: qubes-input-proxy-sender
Version: 1.0.36-1+deb12u1
Priority: optional
Section: utils
Source: qubes-input-proxy
Maintainer: unman <unman@thirdeyesecurity.org>
Installed-Size: 55.3 kB
Depends: libc6 (>= 2.34), qubes-core-agent (>= 3.0.25)
Homepage: http://www.qubes-os.org
Download-Size: 11.0 kB
APT-Manual-Installed: no
APT-Sources: tor+http://deb.qubesosfasa4zl44o4tws22di6kepyzfeqv3tg4e3ztknltfxqrymdad.onion/r4.2/vm bookworm/main amd64 Packages
Description: Provides Simple input events proxy
 This package is intended to run in a qube with physical input device attached
 (for example USB VM). It sends events to a listener in dom0 which passes
 them to an emulated device.

Where are these input events recorded? Is there a log for these input events?

In journal in sys-usb and dom0. You can check the logs using journalctl command.


Is this service related?

would running sys-usb in debug mode be of use? I tried this but it just created

a window with black screen.

could this issue be resource related? Meaning, RAM, or hard drive space.

Here’s an interesing sys-usb entry:

sys-usb dbus-daemon[970]: [session uid=1000 pid=970] Activating service name=‘org.xfce.Xfconf’ requested by ‘:1.10’ (uid=1000 pid=1061 comm="/usr/lib/x86_64-linux-g>

Jun 02 13:30:09 sys-usb sudo[1128]: user : PWD=/home/user ; USER=root ; COMMAND=/bin/systemctl --no-block start qubes-input-sender-mouse@event7.service

Jun 02 13:30:09 sys-usb sudo[1128]: pam_unix(sudo:session): session opened for user root(uid=0) by (uid=1000)

Jun 02 13:30:09 sys-usb sudo[1128]: pam_unix(sudo:session): session closed for user root

Jun 02 13:30:09 sys-usb dbus-daemon[970]: [session uid=1000 pid=970] Successfully activated service ‘org.xfce.Xfconf’

sys-usb uses xfce as a window manager, maybe that’s something to look at.

does dom0 use a window manager?

Or maybe there is an issue with systemd or dbus-daemon /etc/ config files.

You have an error in policy files somewhere.
I’d suggest to remove all your custom policies and use all default policies for a test and if it’ll work then try to add your custom policies one by one.
Related issues:

I don’t have any custom policies. I was always using the default policies.

What’s unclear is why the legacy policy is not being adhered to at all, which could be

because of the .rpmnew suffix.

The new policy format is not being applied either, so the sys-usb VM is in a state

of limbo, with respect to how mouse events are handled.

Is there a command to copy all the .rpmsave files to non .rpmsave files?

I tried copying the contents of qubes.InputKeyboard.rpmsave to

qubes.InputMouse but this had no effect

They need to make this policy transition easier…

Maybe I will find the answer by searching in