Qubes Tools on Windows 10 and loss of networking


I’ve recently setup a Windows 10 Qube and have encountered a persistent bug/issue which I have been unable to overcome despite a great deal of googling and experimenting with various settings.

After installing Windows 10, I have followed the instructions at Contents/windows-tools.md at master · Qubes-Community/Contents · GitHub to setup Tools for clipboard sharing. On a high level, these steps are:

  1. Downloading/installing the XEN xenvbd and xenbus driver packages. Rebooting.
  2. Downloading/executing qubes-tools- and installing without “Move User Profiles” and “Xen PV disk driver” selected. Rebooting.

When Windows is first installed, my networking works fine (I see a single/valid adapter in my Network Settings and can connect to the internet). After installing the xevd and xenbus drivers and rebooting, this is still the case. However, as soon as I install qubes-tools- AND reboot, my network connectivity vanishes. Not only has the network adapter disappeared, but I also am now unable to open my “Network Settings” in control panel (the window will instantly close if I attempt to do this).

Notably, I have attempted every conceivable permutation of the installation options for Tools to attempt to isolate the precise cause of the loss of network connectivity (selecting/not selection XEN network drivers, Move User Profile, XEN PV disk drivers etc). None have made a difference: with whatever settings I install Tools with, upon reboot my network adapter will have disappeared and I will permanently lose network connectivity from my Windows 10 Qube.

Has anyone encountered this issue before, or have an inkling as to why this would be happening? I should emphasize that the only thing I need Qubes Tools for is clipboard access. If I can get clipboard sharing on my Win10 Qube while preserving network access this will be sufficient for me.

1 Like

Please do not duplicate topics, but rather be patient.

You may find some guidelines about this, here

The original post was made in the wrong section and I have no permissions to delete it, nor did a moderator relocate it here. If a moderator sees this please delete the original post in General Discussion along with mine and enmus’ comments in this post so it may be answered and the community benefit.

Windows 10 networking is not nearly as reliable as previous Windows. I have had to perform the Windows 10 network reset on brand spanking new hardware as well as virtual machines. It is quite possible everything was correct with QubesOS, but Win10 itself was broken. Luckily, the Windows 10 network reset is almost always a totally safe operation. WiFi passwords are not lost for instance. But it is so annoying because all the normal network troubleshooting is done before you suspect a “Network reset” is needed. Reboot Required :weary:

Eliminate problems with the special darkened Windows security attention graphics mode - oh what is that screen called:

  1. Until it is figured out, from an elevated admin prompt, userAccountControlSettings.exe and turn it all the way down to “Never notify”.
  2. Use control.exe ncpa.cpl from an already elevated prompt.

One change i have seen relatively recently is that I now have one item in devMGMT.msc showing with a yellow mark - it is “XP0001 XENBUS CONS”, but everything seems to work ok. Definitely have network connectivity and have restarted countless times do Windows updates and tests. However, i started setting these machines up in March of 2021. Currently, running Win10 20h2.

My Windows machines are their own template and the “Run in debug mode” checkbox is checked.

One thing i just noticed is that there are 9.0.0 drivers from 2019 mentioned in your article and much newer drivers from less than two months ago - 2021-12-19. I am still using the 2019 drivers.


1 Like

Came across this forum post which has a link to a 4.1 feature ‘qvm-create-windows-qube’ which looks fantastic!



1 Like

Thank you for this excellent suggestion! I upgraded to 4.1 and attempted to use this command, however it appears this opens up a new can of worms, and I am unable to complete automated install of Qubes Windows Tools. Details on this can be found in my new post at Qvm-create-windows-qube Qubes Windows Tools install hangs infinitely

Interestingly, the broken network adapter issue seems to be showing up again even with the qvm-create-windows-qube command. The XEN network adapter is visible and the Xen drivers were successfully installed (along with Tools) however I am unable to access the internet.

I have problems with the XEN network drivers, too, in Windows 7, 10 and 11. If I don’t install them on QWT installation, my network runs on these machines without problems.

Interestingly, the same issue persists for me even when I do not select XEN network drivers. In fact I can de-select all XEN drivers in the QWT install, and I will still lose networking upon reboot.

As far as I know, if you select network drivers to install with QWT, then you have to manually set networking (IP, subnet, gateway and DNS).
Also, as far as I can remember, Xen 9.x drivers are problematic, and I would try with default 8.2.x drivers

Unfortunately, using the old drivers has not fixed the issue either, however switching to sys-whonix for my NetVM has sporadically solved the problem, although I have no idea why or how.

Uninstalling and installing Xen drivers are often no-go to fix the issue, as I think I read. Creating VM from the scratch with 8…2.x drivers did work for me. I didn’t delete current one, just created another one tocheck if it works. And it did. But I can’t guarantee it’ll work for you.

Why do you think actually this helps? I am not sure abut that at all neither tried it.

Did you try to build it actually?

I wasn’t aware of any other way of doing it, although I know that it is possible to update Qubes Windows Tools from dom0, I’ve never been sure how to actually install it without downloading from within the Windows Qube itself from the link at Contents/windows-tools.md at master · Qubes-Community/Contents · GitHub

Can you clarify how you have been installing Windows Tools into your Windows 10 Qube to get clipboard sharing working?

I followed instructions from the link given above. Built it and then mount it to Windows as described there.

1 Like

Solved the issue. I think its very important that the owner of the Qubes Windows Tools Github repo updates his instructions to reflect that tools v4.1.3 is outdated.

Glad you made it. These are the places to bookmark, subscribe and follow when you have windows qubes.

1 Like