Qubes-specific audio problem with VoIP telephony


I am trying to make a call to the telephone network via my computer. To do this, the Linphone software connects to the router. This works on normal Debian and Ubuntu systems. However, it does not work with absolutely the same settings and the same program version in a Debian AppVM: I can call people and they can call me, but nobody hears anything. I use a headset that is assigned to the AppVM. This is also recognized by Linphone as “PulseAudio: Headset”. Microphone test and audio output test with headset run successfully. During the call, Linphone sends bytes in the upstream direction, but zero bytes flow in the downstream direction.

I have tried everything: Using Linphone under Debian 11 or 12, disabling IPv6, TCP instead of UDP. The audio codecs used are G.711u, G.711a and G.722. The AppVM is connected to sys-firewall. The firewall settings are empty. I use Qubes 4.1.

Would anyone know how to solve this?


I don’t know for sure what Linphone needs but you may need to forward some ports for Linphone to work from sys-net to your Linphone qube:

Linphone uses the port 5061 as SIP/UDP listening port and 7080 as Audio RTP UDP port. I did not know, that I have to open some ports from sys-net to my Linphone Qube. So they are not open by default? How can I open the ports 5061 and 7080?

I don’t know if it’s needed or not as well. It’s just a guess.
Basically you can see sys-net and sys-firewall as two routers and the qube with your Linphone being behind two routers. You can search the internet for problems when using Linphone behind router and how to solve them.
If it needs the port forwarding then follow the guide that I linked in my previous post that describes how to do this.

1 Like

You could be right. I tried to use linphone in sys-net and everything works well. But I am a bit overwhelmed with port forwarding configuration, especially when there is also a sys-vpn between AppVM and sys-firewall.

1 Like

Do you want to use Linphone over VPN?

Yes, there should be a VPN-Connection (or wireguard) to the router.

Did you have the same setup with Linphone over VPN in normal Debian and Ubuntu systems and it worked?

Sorry, no, it’s like this: The phenomena I described here were all as described WITHOUT using VPN. But I would like to add VPN. I just wanted to test the simpler procedure without VPN first to see if at least that works.

I tried it once with sys-vpn. The result: Calls go in and out, but no sound.

If your VPN supports port forwarding then you can configure it to make Linphone work over VPN.
If it doesn’t then you’ll need to search for some other way to make Linphone work over VPN.

1 Like