Qubes slow (out of mem)

i also edited my posts till its correct to my knowledge.

disable balancing would / could fix this? could try this out but im unsure because keepass is freezing also with 4gb ram. since the last reboot everything is running fluent but still using max mem. could maybe disable balancing and downsize my qubes.

oh you are really using only 16gb ram? but these 12-18 qubes arent running at the same time right?
because as i had 16gb ram i ran out of memory (qubes didnt start anymore qubes - so this common message show up like “not enough memory to start qube”.
and i only had opened my daily driver qubes without my “job” qube where i would code,…
also got sometimes the problem that i wasnt able to watch youtube with my 16gb ram.
had to close some tabs that my qube was running well again.
maybe is brave not qubes optimized and thats my problem?

brave is my standard browser because i got the feeling brave is the best privacy browser out there atm.

That’s good and appreciated. Capitalize “i” as well. It’s you!


It would freeze with 64GB as well.

My vault and Keepass in it is running on 400MB.

I told you everything. Now you search and experiment.

So, this topic is about supporting your confidence or about “out of mem”?

… and get back with findings on experiments to help others too.

thats what i said, we are in the internet, wouldnt see the sense to capitalize things here.

yeah, thats the reason why i was wondering why disabling balancing should fix my issue?
and why it should run “fluent” with 400mb. but as i said, i would try it out. thanks for this tip.

sorry, i dont get this answer, tried to translate it with something similiar like google translate (just from startpage) because i only know confidence in a different context.
but to give a answer anyhow:
i dont getting anymore (since i upgraded to 64gb) these “out of mem” messages from qube
so i guess you mean with “out of mem” these “cant start qube” messages.

Here we go again.

whats your problem?
i am not the only person here who isnt capitalizing things and i know you are the only person who is ONLY saying to me that i have capitalize things
i dont want to attack someone but why didnt you told newbie he should capitalize things?
you wrote with him on the same topic here:

clodius is also not capitalizing:

here another one:

and you are still the only person who want that i only capitalize things. in these posts i posted here, nobody got a problem with it that they didnt capitalize theyr words.
also all my previous posts arent capitalized. who cares? if you are googling for a problem it doesnt care you if this post is capitalized or not, the only thing what would be important is, that it would help you further.
but i dont want to continue this discussion, thought we should keep this forum clean.
so everyone who is searching for a topic similiar to mine doesnt have to scroll down over ~100 senseless posts.

Your posts. The answer was in post #2. Any caring user will find answers there.

And contributing things can be found exclusively in my posts. All of them. Not in a single one of yours.

oh you think so? i thought the goal were that everyone could use qubes.
sorry, i misunderstood this then.
asking me then, why qubes should be good for persons who are journalists and never touched linux in any way.
and why qubes is advertising that qubes is good for journalists who are working on sensitive data.

there are 2 ways you are reacting as you react:
1.) you want to be a wannabe senior who forgot the goal of qubes.
2.) you got some complex which you cant process and have to let it out on other people.
maybe you didnt reached a goal or something like that and thats the reason you are acting like someone who act on you like that.

then tell me what were contributing of your posts?
ok maybe only the thing you told me i could disable memory balancing, the rest of it were how i have to write, how i have to ask things,…
thats not the topic of my topic.

and yeah, sure, you never found something contributing on my posts because im a planless dude who was wanted to get some help.
but because you are counting your “tutorial how to ask questions” also as contributing, then my answers should be also a contribute.
because thats my opinion.
i asked my question correctly, i explained what my problem is,… everything should be fine.
but i cant be responsible for that, that you dont read my post meaningful.

this would be my last post.
maybe a forum mod would close this topic and open up a new one for me or something like that without your answers which are so super contributing to the non techie qubes community.


I do a lot of errors when typing. I edit my posts constantly.

But I never get into fights in forum. I decide to pass on and not answer to things I can’t. And breath between things misunderstood and meditate on content of my last post when people ask questions over I already answered. Maybe I shouldn’t have answered if I was not clear enough. Maybe I was not in the right state of mind when I answered. And I learn from that. If the question is too vague, I try to teach without being hurtful, without judging. If I’m writing and I judge, I dismiss my post and I say to myself that someone else will answer, unless I’m tagged. If I’m tagged I answer only when I’m available. We are all here to learn and exchange…

Qubes uses basic , simple, home-made memory ballooning. When a qube is created, its either a hvm with static memory assignment or a pvh qube with dynamic memory assignment, defining max and min memory settings.

When a user starts a qube with dynamic memory and memory balancing enabled, a qube will start with all the memory it needs, including a lot of virtual memory which isn’t really needed. That memory will stay in the qube unless another qube needs to “steal” that memory, which will trigger dom0 memory ballooning which will try to steal unused virtual memory from one to give it to another qube. Unfortunately I do not know all the details here, but the result of this is that qubes will show less memory usage in active qubes widget over time.

What you seem to observe is two separate things: you are one of the lucky one having 64gb of ram, which means all qubes can use their maximum dynamic memory settings at the same time. Until all 64gb are used across qubes and dom0. At that point, and when that happens, slowness could happen, but should not happen prior of that point unless all applications are actively used (cpu actually trying to do something in that allocated memory).

So to separate things:

  • having your qubes use maximum dynamic memory setting is normal until physical memory constraints are met.
  • crashing or slowness should not happen until those 64gb of ram are physically used + swap space
  • somewhere in the middle of this is those 4gb of ram actually being reserved and used, with slowness happening which involves in-vm memory being swapped to qube’s swap partition and or dom0’s swap switching in-memory with disk swap because too much memory is actually being physically used. From what you describe this is not the case.

Now. Other threads will talk about current issues with performance. On my side, everything updated, I experience critical slowness as opposed to months ago on my x230 when one qube is actually using all it’s ram (8gb) and hugging its two assigned cpus, leaving little place for others to do their work, and where other qubes are balancing as they can (16gb physical memory here), reducing performance to the point dom0’s controlled mouse input stops reacting to my movements. That was not like that before where dom0 stayed responsive in that case. I have not yet isolated the issue but I know i’m not alone reading other threads and searching and posting where relevant.

Those changes if behavior are definitely not normal, but an understandable consequence of attempts fixing known issues from Qubes OS side and lack of actual testing of testing packages before they land into stable repositories, which I am partly responsible because I do not always test and report bugs on testing packages as many other advanced users, by lack of time testing those packages on my daily used laptop. There are separate issues you might have missed.

Question here is which model of hardware and describing hardware model, cpu and difference of behavior since approximately when.

In other terms: Was it always like that on that particular piece of hardware? Is it happening under specific workload happening under certain templates based qubes?

I see this post having quickly slide into nonconstructive posts and i’m sorry about that. On the other hand, I know nothing about your machine outside of a memory upgrade you recently did. What would be helpful is to know what were those memory chips. Were they optimal for your hardware? Are they the cause of your now experienced slowness as opposed to before?

Otherwise this post, as of now can be read as: “Qubes OS is slow on a 64gb machine”. Unfortunately, there is nothing actionable on that statement, where I agree second post of this thread said the same things I said previously, but in different words, on memory ballooning of qubes and telling you this is quite normal. But slowness is not.

So more detail on what was used before, and now would help. Machine details (hcl is better) would help everyone trying to help you back.

I was trying here. Sorry if I missed details trying to skim nonconstructive replies in this thread. If important details were missed, sorry but not sorry.

Please restate them (quite relevant parts) and try to not take language differences personal. I’m also not native english. And i’m not sorry about this. And I also not capitalize all my “I”. My goal is to help. Not to be always perfect. But everyone is different and I don’t care. Aho.

Short version:

  • Title of this issue is misleading considering provided information. You might want to rename it since nothing points to " out of mem"
  • You seem to experience slowness. But what is the point of reference on that same hardware? Share a hcl report maybe?

thanks for spreading love over this forum <3
im also more team love in the internet, knowledge should be available for everyone. there are 2 things why people arent asking precisely:
1.) he really doesnt get that knowledge
2.) people didnt searched in the web for theyr question
2. point ive done, didnt found my problem really.
and i also agree, if the other person is still asking although you answered the question, its possible that your answer wasnt that precise or the other person didnt got that knowledge.
i worked in a callcenter, i also had to learn answering people (also non techis)
everyone (especially in the internet) is on a different knowledge level.
and i guess our (or qubes) vision is, to be able to offer qubes to everyone who wants to life in a free and privacy friendly vicinity.
thanks for spreading some love <3

yeah, im using pvh mode exclusively besides of hvm qubes but i didnt got some since this laptop is running on a fresh setup.

no problem that you dont know the details about ballooning.
but thanks for this “detailed” explanation (for me detailed, probably for an advanced user you could explain much more, but this makes sense for me, thought this is a error because with my 16gb ram all my qubes were scaled)

i read this point ~5 times but im unsure if i got this.
if my qube is using more than 4gb (maxmem) ram, it would write into my dom0 swap?
didnt checked my dom0 swap, but as you said, wouldnt believe that this was the case because if so, then dom0 should be also slower?

laptop: lenovo p15v
cpu: intel i7-10850
ram now: https://www.amazon.de/gp/product/B07ZLCVKPV/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1
stock ram: Lenovo ARBEITSSPEICHER 16G DDR4 3200 SODIMM Samsung

behavior is since i swapped my ram and my nvme. reinstalled qubes and yeah, tried to setup the new qubes os as the one before were.
since the last vm freeze (shortly after the installation) i didnt had it, that was also my question, if it could be, that my new nvme ssd is getting hotter than the one before?
wouldnt assume that because the one before also got a thermal bad - if that was enough for the nvme before, it should be also enough for this one?
because if the nvme is getting to hot it would slow down and at some point would stop working afaik.
but this wouldnt make sense again for me because dom0 were responsive.
if it would be a thermal problem dom0 should be also a bit slower right?

with the 16gb ram i never expected this.
if its happening under specific workload, idk. i had this issue 2x after the new installation and since then, everything is ok again.
lets see, ive didnt done that much anymore since the second time.
lets see if i could figure something like that out later (tomorrow)

maybe i find something what could stress my nvme.

but i wouldnt assume its about special qubes.

oh oh. dont say nonconstructive lol
in enmus opinion it was contributing lol
but you dont have to be sorry. every community got some… strange people. :slight_smile:
i wouldnt take that personal. i thought i knew qubes vision and people like you are confirming the vision of qubes. :slight_smile:

you should got now my setup, lenovo p15v gen1, cpu info and i also send you the amazon ram link.
anyhow, i would post here also the hcl as you mentioned it anywhere below.

thanks again <3
didnt know what you would need for a better help… i mean yeah ok to be fair, to post the hardware were also bit logic, but didnt thought about it, so sorry.

this should be a knowledge base and no wordbook.

sorry to ask, did you got a better topic title idea? tried to give my best but, since im trudge in the dark, idk how to call it better.

guess we wrote a while ago but never took a look at your profile - are you the owner of insurgo? thought you just got the name of the company o.O
if you would be the owner of it, i would have respect to you, i mean, you must be pretty busy with a business nearby.
anyhow, would be thankful to everyone who would help me. :slight_smile:

Qubes-HCL-LENOVO-20TRS1QE00-20221129-213457.yml (846 Bytes)

Those were the most important questions, beside memory bought being best for your hardware, which I didn’t digged into yet and would prefer you to answer.

From your answer, you seem to say that the behavior was better with 16gb of ram, same Q4.1 defaults, same laptop, right?

Have you made sure your laptop requirements for maximum memory perf matched the ram modules you bought?

Other then that, I doubt this post will be useful to anybody else having to skim through. I would advise creating another one and flagging mods for suppression of this one, and creating a new one, better named, based on learned experience. What do you think?

You are right. I am senior in recognizing seniors in whining and expecting others to resolve their issues. Here’s my bet from the quote above: if you don’t stop whining and not putting personal effort to resolve your issue while showing that, you won’t resolve this issue and you will eventually blame it on someone/something else: me, @Insurgo, your hardware, and most probably on Qubes or all together, but not yourself.

They use the maximum memory because you have free memory available. If your system has memory to give, any qube you start will be given the maximum memory.

Once you don’t have any more free memory, you will start to see the memory being balanced between the qubes.

1 Like

as far i understood it should be compatible. crucials website is saying that.

i didnt told you a thing because my guess were nvme is overheating but this guess is now death.
because when my appvms freezed yesterday i rebooted and got the feeling it takes pretty long.
thought ok, nvmes getting slower if they are hot. but this cant be the case today because i got in my living room ~20°C and my laptop were shut down the whole time i were away ~8h
i would say my qubes needs to startup ~5 minutes? i watched the process and its hanging up in the “starting qubes” step
what i also watched is, my sys-usb is set up to start on startup but it doesnt.
is my qubes installation corrupt in some way? am i able to check this?

after the fresh installation (1. reboot ive done after updating qubes) everything were fine, qube started in a normal speed as we are all are used to it.

uh, idk what do you mean precisely but, i would say yes - i googled my cpu model and its saying my cpu is able to get up till 128gb ram.

guess this wouldnt make a difference… seems like enmus cant quit trolling here.

oh nice. why are you here then? my motto is always, treat other as you want to get treated.
if you expecting that other people would fix theyr own problems you are in the wrong forum because as i said - qubes vision is to make qubes usable for everyone.
not for only sys admins.
if you are searching a community like this, switch to arch or gentoo but dont waste our time please.
as insurgo already said - what are you doing doesnt move us forward, this is nonconstructive and doesnt “contribute” to anyone as you was telling it.
this should be a knowledge base for everyone, but got the feeling you arent getting it in any way.
got doubt in your intelligence.
if you cant answer to a post and you didnt got tagged to it, why are you writing here?
i never wrote @enmus please help me, you are the only person who could know that or something like that.
what you are doing is trolling here like a kiddo.
were it so complicated to give an answer like insurgo to explain how ballooning is working?
ok to be fair, renehoj answered it also without any problems. you are the only person who is makes a problem out of it.

hold on, this doesnt make any sense of what youve wrote.
im not whining and im putting in it personal effort. as you were able to see, im always answering you although i could ignore you.
i answered insurgo with all details because he was wanted to help me.
this answeres are also personal effort. i just dont know how to troubleshoot this at the best.

“you wont resolve the issue and you will eventually blame it on someone or something else”
yeah what would be the reason why i wont would fix my issue? i mean my first question about ballooning is “fixed” cause insurgo and renehoj answered it.
so why should i blame it on qubes or someone? seems like you didnt know that because, if you knew that your second post would be something different than, you should disable balancing.
answeres like this would people blame on qubes, because they are thinking memory balancing isnt working and qubes dev team is too dumb to fix it.
but thanks to insurgo that he correct the answer of yours.
and yep, i would blame it on you. because you are in the wrong community.
blaming on insurgo… do you read what you are writing? this wouldnt make sense, why should i ever blame it on someone who was helping me out and put so much effort?
i mean his first answer took him for sure ~10 minutes? maybe longer? maybe shorter?
if anyone doesnt want to help you he would give answers like you. this is gentoo community spirit.

never would blame it on my hardware for no reason, we are troubleshooting here, i cant exclude my hardware here.
insurgo also doesnt because maybe the ram is incompatible with my laptop.

uhm… “or all together”.
you know how that is happening? people who doesnt get good technical understanding, searching for help but dont receive it.
those people are the ones who would blame it on all together.

i know a person who is acting like that because of reasons like you. he searched the web, searched forums, asked in the forums but didnt got help…
but if we all helping those people, they would never blame it on someone.

to be fair, im blaming much on myself, i got anxiety and depression. tried to kill myself for several times.
i know that i be a dumb person who never reached anything in my life.
i just wanted to get some help, but you dont give me one.
was thinking to delete my account on that forum because i thought the community got changed.

but… now insurgo and renehoj answered me to my problems and its just a dumb person… why should i delete it because of 1 person?

if you dont want help, its fine, as you can see, there are more than enough people here who are willing.
so this would be my last answer to you because i hate this toxic behave as you are doing.
i dont need it
just always think: treat other as you want to get treated.
if you ever meet a person like you, you arent allowed to blame him because you treated others also like this.
but anyhow, you are treating everyone like this, i read the gitlab vs github topic and you also discussed with sven about this topic.
and i also didnt liked it how you treated newbie.
as he said, he is a newbie and just curious… anyhow… i got on myself too many problems.
but you know what? i searched also help for my depression and anxiety.
probably you should also search for some help because this behave isnt normal.

thanks, insurgo already told me this :slight_smile:
but really, thanks. one thing less to troubleshoot lol

oh btw. you dont using graphene right? then you would also know why people are blaming something.
its because they got misinformation or dont know how it woks.
thats also the reason why we always answer other people. so they could getting smarter and then they would also maybe appreciate some things more.
thats how graphene is always getting blamed from calyx community.

Your original ram module was:

New one is: Crucial RAM 64GB (2x32GB) DDR4 3200MHz CL22 (2933MHz oder 2666MHz)

Edit: Wrong model.

Model from HCL is 20TRS1QE00.

Memory chosen is right.

1 Like

oh wait, you are watching at gen 3

i got gen 1

1 Like

What happens exactly? Freeze? Shutdown?
What does the logs under dom0 say for those “qubes stopping to work”?

From what you report, ram is ok, compatible with your laptop and of good quality.

Now what about your nvme?

You need to give more details about what is observed.
Unfortunately I do not think I will be of better help in this thread.

You could do a memtest to make sure memory is ok. From here I do not see ram as being an issue.

Other threads could be opened and searched for:

  • memtest
  • nvme performance
  • nvme temperature monitoring
1 Like

yeah something like freezing, my appvms ui would be pretty unusable - but for all appvms if this happens.
didnt got this problem today…
as example: yesterday i was wanted to switch my tab from youtube to another tab and then it loaded for years
then i got a signal message, was wanted to answer but were unable to send it
thought ok, i would continue work on my browser which loaded for years and werent able to scroll
then i tried to use keepass and this one also hang up.

but as i said, didnt expect it today (till yet).
but boot process is still weird.
didnt start my sys usb qube automatically / boot process hang up shortly.

my nvme is a 2tb wd blue
to be precise, this one:

would search for memtest soon! first have to get things done!

but seems like you dont expect that my qubes install is corrupt?

thanks for your answers till now.

would get into detail later, as i said, have to get some things done now :slight_smile:

little update for people who are interested:
using now 55gb ram and didnt got any problems anymore. seems like only this boot problem is still remaining but i could life with it anyhow. maybe i would reinstall qubes one day and check if this would fix my problem but… i dont really care about it atm.

just happy that my qubes is running without any problems :slight_smile:
maybe i could find anywhere in the forum a topic similiar to my boot problem / qube starting problem.