Qubes R4.2: How do I right click? Is there a way to move files back and forth between qubes with cli?

I am wondering if there is a way to fix keyboard/trackpad issues on System 76 (~NV41 NovaCustom - Qubes Certified EC?) on Qubes R4.2. How do I right click? Is there a way to move files back and forth between qubes with cli?


p.s. Does anyone know why Google Captchas are so weird?

Perhaps you could tell us more: which issues exactly do you experience?

At least on a touchpad, you can right click by clicking with two fingers.

qvm-copy and qvm-move.

Also, you should create separate topics for separate questions, otherwise new users will have a hard time finding answers on this forum.

1 Like

I will clarify the question. The question is related to several subtopics. The primary question, however, is about CAPTCHA fingerprinting and about how successful CAPTCHA answers are blocked.

qvm-copy and qvm-move are already documented. How to fix hardware EC so that the trackpad can right-click is not. Two fingers do not do it. Nor a combination of shift and click. I will probably just use the cli. I thought someone might have another idea.


But, actually, there seems to be a way to block CAPTCHA on multiple devices. I have tried to complete CAPTCHAs (Google not cloudflare) several times and there appears to be some way to block the solution across multiple devices (smart phone and laptop). To focus on the most recent issue, I tried to get the CAPTCHA for ‘signal-cli’ registration (since laptops have higher entropy than embedded) but the Google CAPTCHA (like everything Google proprietary) is blocking my attempts. It is too bad Signal depends on proprietary Google code since Google is known to violate privacy. I have witnessed Google (In-Q-tel) pwn devices several times, perpetrate unauthorized access on personal property.

Hi @procShield this is a forum about Qubes OS. As such we focus only on Qubes stuff. For this this readon I have changed the title to the Qubes stuff and I’ve hidden some content regarding the captcha issue to make sure we stay on-topic. I hope you understand.


For the two-finger method to work you need to first enable “Tap touchpad to click” in the “Touchpad” tab of the “Devices” tab of the “Mouse and Touchpad” app in dom0 (while the touchpad is selected in the device choicebox there).

That will active tap to click, such that one finger tapping is equivalent to a left mouse button click, a two finger tap to a right mouse button click and a three finger tap (all mentioned taps are simultaneously using that number of fingers, not sequentially) is like a middle mouse button click.

Most if not all touchpads also have physical buttons “beneath the surface”, e.g. the NV41 you mentioned has all three mouse buttons as physical buttons beneath the bottom portion of the touchpad.

1 Like

Thank you. You’re right. The trackpad isn’t exactly the same as the NV41 but now copy and move with click works.

Just in case anyone was curious,

I think I might try to make an Android vm and install Signal. I have Molly on my embedded which subtracts the Google from Signal so the CAPTCHA won’t link. But Signal in an Android qube should work and that way if Google Play attacks the ROM (which I have seen happen many times even when sandboxed by GOS) then the qube is disposable.

I still am kind of curious about CAPTCHAS. The question could be related to deep fingerprinting in Whonix which is a privacy and anonymity OS part of Qubes. Another topic might also be called “encrypted communication in Quebes OS,” e.g. how to use Hexchat and other applications available in Qubes.

I have seen impossible to solve CAPTCHAS from platforms like X and I can’t get my independent journalism out because the CAPTCHA must identify the device as too highly encrypted and anonymous so it won’t allow access. I have to wonder how that happens. Mystery to me.