Qubes R4.1.1 updating Fedora-36

anybody running into errors updating fedora-36, whonix-16 templates? getting error message: no such domain: disp-mgmt-fedora-36 disp-mgmt-whonix-ws-16

No so far. Updated yesterday some fedora and whonix templates.

how can I fix this error?

More info is needed. Can you update manually with dnf?

how to do this? Is there documentation for this command?

It says the template is already installed

Open fedora terminal and run sudo dnf update and then you may try upgrade

1 Like

Alright so it returned an error:

Errors during downloading metadata for repository ‘qubes-dom0-cached’:

  • Curl error (37): Couldn’t read a file:// file for file:///var/lib/qubes/updates/repodata/repomd.xml [Couldn’t open file /var/lib/qubes/updates/repodata/repomd.xml]
    Error: Failed to download metadata for repo ‘qubes-dom0-cached’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

Try sudo dnf clean all then try to update.

Ok; I tried that command, still getting the same error message.

Try to (re)install qubes-mgmt-salt-vm-connector in fedora template.
If you can’t install, or you can but it doesn’t help I’d now try to rename fedora template, to download fresh one and to try to to update it.

How to do this?