Qubes OS R4.1.2 : Xen must be loaded at a 2Mb boundary

I’m trying to install Qubes R4.1.2 on Samsung Galaxy Book2 Pro 360.
I have been doing a dozen of installations this afternoon, every time there’s no boot option at the end. The laptop restarts and goes “All boot options are tried. Press F4 to recover with factory image using Recovery or any other key for next boot loop iteration”.
When pressing the boot choice key, it only show the “UEFI Setup” option, nothing else.

What I did was a Qubes OS install without editing any defaults, I only kept two partitions at the end of my drive (SAMSUNG-REC1 and -REC2) in order to be able to reinstall Windows from the BIOS if needed. The installer outputs no error.

I then tried to follow this doc : UEFI troubleshooting | Qubes OS (Device not recognized after installing bullet point) from the install’s rescue mode. But, there’s no xen.cfg file in /boot/efi/EFI/qubes/. I tried to create it using the next bullet point in the docs, I succeeded to add a Qubes boot option using efibootmgr, but selecting it outputs this error for a millisecond (had to capture it with my phone and slow down the video to be able to read) “Xen must be loaded at a 2Mb boudary”

What can I do ?

did you try with grubx64.efi instead of xen.efi?

efibootmgr -v -c -u -L Qubes -l /EFI/qubes/grubx64.efi -d /dev/sda -p 1

(replace /dev/sda with your disk name and -p 1 with your /boot/efi partition number)

You can also try to dig in the forum: