Qubes OS possible on TUXEDO InfinityBook Pro 16 - Gen8?

I installed Qubes OS on TUXEDO InfinityBook Pro 16 - Gen8, after checking HCL List and recognized not so bad results with TUXEDO Infinity Books.

Unfortunately I cannot find WIFI, and Graphic is poor, Trackpad moves are sticky.

My question is, how to fix that? I am not very experienced Linux user…

The configuration is listed below:
| |Omnia Display | 2560 x 1600 | 16:10 | 240Hz|
|Opt. |Intel Iris Xe Graphics | Silbernes Gehäuse|
|Opt. |32 GB (1x 32GB) DDR5 4800MHz Samsung|
|Opt. |32 GB (1x 32GB) DDR5 4800MHz Samsung|
|Opt. |Intel Core i7-13700H (max. 5.00GHz 14-Cores, 20 Threads, 24MB Cache, 45W TDP)|
|Opt. |2 TB Samsung 990 PRO (NVMe PCIe 4.0)|
|Opt. |ohne M.2 SSD 2 (Nachträglich aufrüstbar)|
|Opt. |Tastaturlayout DEUTSCH (DE-DE)|
|Opt. |Intel Wi-Fi 6 AX201 (802.11ax | 2,4 & 5 GHz | Bluetooth 5.2)|
|Opt. |TUXEDO OS (Empfehlung)|
|Opt. |ohne virtuelles Windows|
|Opt. |USB zu LAN Adapter - Typ-A - 1GBit USB3.0|
Thank you for helping me!

What Qubes version did you install?

On Qubes OS, there is no graphical acceleration for security reasons. That’s why it appears sluggish.

xen_version: 4.14.5
LNUX 5.15.52-1.fr32.qubes.x86_64

He means the version of QubesOS itself, e.g. Qubes 4.0, 4.1 etc…but by the looks of your Xen version and kernel version I don’t think you installed 4.1.2, as that has Xen 4.14.6 and a newer kernel IIRC, but you can run cat /etc/os-release in a dom0 terminal to see the full version in the line starting with PRETTY_NAME.

As to the issues: try connecting to the internet via LAN so you can update everything, maybe that will already improve things. Regarding WiFi you might be missing firmware packages; you can also try switching sys-net to a different template. Regarding touchpad you can try playing with the settings (Alt+F3 and then type mouse and Enter).

1 Like

Ah okay, that ist Qubes 4.1.1 (R4.1)

I already ran an update via LAN, but I will try with firmware packages.

How to solve the graphic problem? Graphic is very laggy is the resolution maybe too fine?
Resolution setting is 2560x1600, but its not possible to change to another…

Make sure you install the firmware packages in the template of your sys-net qube (and then restart sys-net after shutting down the template) and not in dom0. Or you can install a fresh debian-12 template and use that for your sys-net template, as I have the same WiFi adapter and with debian-12 it works without installing any additional firmware packages. Do beware, however, that you should set the updateVM of dom0 either to sys-whonix and update over tor or choose a different template for sys-firewall than debian-12-dvm, as debian-12-based updateVMs cause problems with updating dom0 right now due to a bug.

Regarding graphics: first check if your iGPU is actually loaded (type in dom0 terminal): lspci -n -n -k | grep -A 2 -e VGA -e 3D. Also: what is laggy? The overall environment or stuff like videos or games running in non-dom0 qubes?

Hmm, in sys-net cube there is in Settings - Template no debian available. Only fedora-36-dvm and Whonix-ws-16-dvm

in sys-whonix cube is in Settings - Template available:

I don´t know how to insall firmware packages, must look first how to do this…

Result of the command in dom0 terminal:
VGA compatible controller (0300): Intel Corportaion Device (8086:a7a0) (rev 04)
DeviceName: Onboard - Video
Subsystem: Tongfang Hongkong Limited Device (1d05:124a)

The overall environment is laggy; I dont have videos or games in the system yet :slight_smile:

Regarding graphics: I’m also no expert in Linux, but IIUC if there is no “kernel driver in use”-line for the lspci command I gave above then your iGPU is not active. You can look into xl dmesg and sudo dmesg (from dom0 terminal) to try to see any specific errors (try looking for, e.g. “VGA”). Until then you can try to reduce the load by:

  1. reducing resolution → Alt+F3, type display and Enter
  2. reducing effects or compositing in general → Alt+F3, type window, select “Window Manager Tweaks” and Enter; there try disabling everything or some things in the “Compositor” tab

Regarding networking: you need to install a new template in dom0: sudo qubes-dom0-update --console --show-output --releasever=4.1 qubes-template-debian-12
To change templates you need to shut down the VM first.

@Pitty Did you try my suggestions? Why have you opened a new topic with the same questions?

Yes, I tried, after new setup again things got worse. I am maybe not able to setup Qubes at Tuxedo Laptop and very frustrated.

The tip with Window Manager tweaks worked well!

But now I have no Network, nor LAN either WLAN… and I don’t know what I did different.

Going by your other topic’s question I take it that you again installed Q4.1.1.

The latest version of QubesOS is 4.1.2, however; it includes many fixes for a great variety of issues. You should download, verify the the signature of, and install the latest version. You could also try the latest release candidate for Qubes 4.2 - R4.2.0-rc4 (you’ll also find that under the same link).

Maybe anyone here is able to help me with my Tuxedo?

After Installation Qubes 4.1.1 there is no network, no wifi available. Also graphic is very laggy.

  1. how to solve the network problem, so that I maybe can run an update
    2 how to adjust the graphic


I merged both your topics @Pitty

Both your topics were very similar, so I merged them here. It is not helpful usually to open more than one thread per topic, and that makes it more difficult, not easier, for folks to help you, or find information useful for them if they have similar issues.

Please try to keep related posts together. :slightly_smiling_face:

Thanks a lot Bearillo!
I now installed Version Qubes OS 4.1.2, helps a lot, but didn´t solve graphic issuses. Enabling things in Window Manager Tweaks helped a little, but Videos dont run, also Graphic is horrible. Switching to a lower resolution maybe could help, but is not Possible because greyed out?!
Also now I have no sound.
That are the next issues to solve:

  1. make my Graphic run perfect
  2. make Sound run
  3. make WIFI run

There just came an update for dom0, it looks like Problems solved!!! :grin:

Good! Feel free to mark a post as the solution and enjoy real security!

Unfortunately not yet:

Video is not running good in Browsers (like YouTube). The Video is jerking extremely
How can I adjust this?

GPU acceleration for VMs other than dom0 is not currently supported in QubesOS, so this is expected.

What I usually do is assign all cores and generous RAM to the VM (Qubes Manager, select qube, click on Settings button, go to the ‘Advanced’ tab) that I want to run a video in (and restart the VM if it was running, so the changes take effect), make sure that it isn’t trying to stream in 4k, and for YouTube especially: make sure you turn off the extremely resource intensive “Ambient Mode” (in the settings of the YT player). The quickest way to get that video (almost) full screen btw. is to use the Picture in Picture mode of the browser and maximize the resulting window.

The only alternative AFAIK is to try to get PCI passthrough with an external (second) GPU and a separate monitor to work, but that is quite the hassle.

That didn´t work, but thats really weird:

these embedded videos are running in firefox esr under debian, but are sticky in firefox under fedora! I made new qube with debian and now it is running…

How can I check if all components are running perfect? Then I would provide a HCL List, maybe helpful for others…

To test more components just use the system for more tasks; I don’t think anyone actually tests literally all components before submitting an HCL report. To do the latter (from the docs):

In order to generate an HCL report in Qubes, simply open a terminal in dom0 (Applications Menu > Terminal Emulator) and run qubes-hcl-report , where is the name of the qube in which the generated HCL files will be saved.
You are encouraged to submit your HCL report for the benefit of further Qubes development and other users. When submitting reports, test the hardware yourself, if possible. If you would like to submit your HCL report, please copy and paste the contents of the HCL Info .yml file into an email to the qubes-users mailing list with the subject HCL - , or create a post in the HCL Reports category of the forum. Pasting the contents into the email or post has the advantage that members of the mailing list and the forum can see the report without downloading and opening a file. In addition, new forum members are unable to attach files to posts.
Please include any useful information about any Qubes features you may have tested (see the legend below), as well as general machine compatibility (video, networking, sleep, etc.). Please consider sending the HCL Support Files .cpio.gz file as well. To generate these add the -s or --support command line option.
Please note: The HCL Support Files may contain numerous hardware details, including serial numbers. If, for privacy or security reasons, you do not wish to make this information public, please do not post the .cpio.gz file on a public mailing list or forum.

1 Like