Qubes OS not booting from USB after successful installation

I tried to install Qubes OS on a USB flash drive IT installs successfully every time but doesn’t boot from boot menu disk.

I tried a solution from UEFI Troubleshooting page

Boot device not recognized after installing

[I copied all the files of “/boot/efi/EFI/qubes/” to “/boot/efi/EFI/BOOT” and renamed them as it says. By doing this I can boot Qubes from a boot option called “Boot form file”. But it cannot be booted directly form boot menu where my USB stick is listed. Only opens when I boot the file “/boot/efi/EFI/BOOT/grubx64.efi”]

Then I saw another solution Installation finished but “Qubes” boot option is missing and xen.cfg is empty / Installation fails with “failed to set new efi boot target”

Here I noticed I don’t have 3 files it mentions

  1. xen.cfg (empty, size 0)
  2. vmlinuz-(kernel-version)
  3. initramfs-(kernel-version).img

I am not a advanced linux user and new to Qubes. I don’t know how to make those files. And stuck here for a day.
Please tell me a easy fix I don’t understand most of the linux things.

I am using a HP laptop. Virtualization is on. Secure boot disabled and Legacy boot disabled. Fast boot unchecked.

These are the available files of boot menu of Qubes OS after a fresh installation.

[partitions] https://drive.google.com/file/d/1lr4iUb4y-I8CaJLJ2Dy0wgcF-_HQCqIS/view?usp=share_link

[boot files] https://drive.google.com/file/d/1ZsuIeNec7Dp6dxnTNcOeQaVowqPWNqgA/view?usp=share_link

It is not quite clear to me what exactly is error, but there are other possible cases for which solutions are on

Also, this is pretty self-explanatory

and it’s not Qubes specific. You just need to follow commands stated there. If the file are not there, then I don’t know how would I think my installation was successful. I’d do it from the scratch, but this time I’d ask my self

Did I try CSM, or Legacy mode enabled?

Aldo, there are a lot of similar topics on the forum

https://forum.qubes-os.org/search?q=Qubes%20OS%20not%20booting%20from%20USB%20after%20successful%20installation

1 Like

I am running Qubes now. Everything seems fine, no error.
I have to boot it from Boot Menu > Boot From File > A partition > /EFI/qubes/grubx64.efi
The problem I had and still have is if I select the USB drive from boot menu it doesn’t boot anything. Somehow boot file(s) or EFI boot partition couldn’t be detected. (maybe efibootmgr would work. I will try that later.)

I made the question because I didn’t see the 3 files, I mentioned earlier, which made me confused and I still couldn’t find them. But it works fine and I’m okay with that.

My solution until now:
Just boot it from:
Boot Menu > Boot From File > ["/boot/efi" partition of qubes os] >
/EFI/qubes/grubx64.efi