Qubes OS is not showing in the BIOS menu after unplugging and plugging the SSD again

I have been using Qubes successfully for over 2 months, but when I unplugged and plugged the SSD again it no longer appears as an option on the BIOS.

I have followed this guide:

But when I enter that command on the installation media shell:
efibootmgr -v
it says EFI Variables are not supported on this system. Same error appears when I try to enter the command:

Also, when I try to go with the option Rescue Qubes OS, it asks for sda3 password, I then enter the password and it says “You dont have any Linux partitions. Rebooting.”

What should I do to recover my Qubes OS now?

Maybe you booted your installation media in Legacy BIOS mode and not in UEFI mode?

And how do I boot it into UEFI mode? I just launched the installation media normally

You can disable Legacy BIOS or CSM support in BIOS and then only UEFI will be used.
Or just try different boot entry from the one that you tried before.

I just did that, its not in UEFI mode but still I dont know how to proceed. When I type fdisk -l it shows this:

How to proceed?

You need to run this command instead:

efibootmgr -v -c -u -L QubesOS -l /EFI/qubes/grubx64.efi -d /dev/sda -p 1

Thank you very much, it worked!
Do you know why the Qubes option disappears from the boot menu if the ssd is unplugged? And if there is a way to prevent it in the future?

Check this issue:

There’s info about this problem and a way to prevent this in the future.

What should i put for ‘-p’ and ‘-d’ here

Edit: some context here - im ramdonly unable to boot after using qubes for about a month.

Ive tried rescue mode but option 1 says “you dont have any linux partitions”

Some other information: I multi-boot qubes, and 2 windows OS. Using lenovo legion 5

efibootmgr -v -c -u -L QubesOS -l /EFI/qubes/grubx64.efi -d /dev/nvme0n1 -p 1

Thank you for the timely response!

I tried this but im still having issues booting qubes :frowning:

Where do i go from here?

So do you still miss the Qubes OS boot menu entry in your BIOS?
Or you have it but it’s just fails to boot?
If it fails to boot then how exactly does it fail?

Its from this thread. QubesOS stuck at boot - #14 by apparatus

I tried to boot from qubes liveusb.

Im on this thread trying other solutions but im not techie enough to know what im doing lol

Ive tried rescue mode too but its tellling me theres no linux partitions.

Trying to boot normally gives me this result after entering LUKS password

You need to check the log to see why did it fail.

I see. I tried the solutions but i just couldnt get it to work. It wouldnt detect my external usb so i couldnt mount it. I think ill just re install qubes. How can i stop this from happening again?

You can copy the file to /dev/nvme0n1p1 and then boot from another system and get it from there.

Without logs I don’t know what happened.

I can boot any linux based OS? I have other non linux OS but im unable to viee the contents?

Also, how would i view them on a linux os if its encrypted?

If you copied the rdsosreport.txt to the /dev/nvme0n1p1 partition which is EFI System partition, you can access this file in any OS. It has a FAT filesystem so even Windows can see it.

Ive tried viewing it on win 10 but its seems it a rather complicated process to do this since it wont give me permission to view contents of the folder. I have spent some time on forums seeing how to get access but it seems rather complicated and i cant afford to lose my daily driver OS.

Why couldnt my qubes os detect any of my usbs?

Im thinking of giving up on this tbh

Then boot in Qubes OS installer shell and copy this file from your EFI System partition to your USB.