Qubes OS installer keeps on restarting after starting the installation process

So Im trying to install Qubes 4.1.1 on a 480GBs USB stick.

Now whenever I select any option from the installation menu it will end up restarting (you can see that in the videos I’ve attached in the end of this thread)

So I make this thread so you guys can tell me things to try out etc.

I tried different things to solve it:

  1. Verifying the ISO with PGP
  2. Using different tools to flash the ISO to the USB stick
  3. Using different laptops to do the installation (in one of them it had more progress but still didnt manage to get to the actual UI of the installation)
  4. Using different USB stick

Keep in mind that my menu is black and white, which I think it should had been cyan and white?

Also, this laptop supposedly has 2 GPUs, when I open task manager on windows, it shows 2 GPUs, one named “RTX 3080 Laptop GPU” and the second named “AMD Radeon Graphics”

Videos: 126.02 MB folder on MEGA

Did different laptops also had 2 GPUs? Most probably it’s about your RTX GPU, and there are a lot of topics here about such and issue.

Also, you’d want to check these


But it could be a tons of other things, like setting your BIOS, etc… All is also well documented here on forum.

in the different laptop that has more progress, it only has 1 GPU called Intel UDH Graphics 600.

Here is a video of what it does: 25.05 MB file on MEGA

Oh and by the way, the first link you sent, I’ve read this again and again, did everything I could from them and nothing worked, as for the second link, its about issues you can face in your qubes OS, not in the installation of it.

I cannot find anyone else with the same issue as me and im not that advanced in virtualization so some stuff are hard for me to understand without someone explaining it, im sorry…

Edit: Contents/nvidia-troubleshooting.md at master · Qubes-Community/Contents · GitHub here it says to disable Nouveau but to be honest I dont understand how to do that.

nouveau is the kernel module/driver for Nvidia cards … I guess the same module for “Intel UHD Graphics 600” is called i915.

To edit the commandline at boot, press e when you have “Install Qubes OS” highlighted - it should show you something like:

setparams 'Install Qubes OS'

  multiboot2 /images/pxeboot/xen.gz console=none
  module2 /images/pxeboot/vmlinuz ... quiet
  module2 /images/pxeboot/initrd.img

The line that ends with none is the options for Xen (the hypervisor) … and the line with quiet is the kernel. If you remove the quiet, then you should get some extra [debug] information. When you are done editing the arguments, press ctrl+x to boot with the options you’ve set.

Since anaconda (the installer) seems to actually start, it might be sufficient to just boot again and press alt+tab to get a text console and do some debugging from there (?).

If you need to set some module options wrt. i915, you can put them after quiet – searching the forum for “i915” have some suggestions.

1 Like

Thanks for replying.
I was gonna test this but then I remembered I know someone who has a old pc with Intel CPU and Intel GPU so I tried to run the installer and it worked haha, I was able to install the OS and everything that comes with it, then I restarted the computer and this time booted from the USB stick I wanted and it booted successfully and I was in, I couldnt test it further since the PC doesnt support virtualization so I didnt tried running any VMs etc but anyways, I shut it down and went home to try running it from my own laptop but now the laptop doesnt boot from it, it does see the USB stick and it reads his name, but doesnt realize that its bootable, I did some research and found steps to fix this in both the official qubes website and the qubes forum.

I dont know how to do that so I searched on this forum and found this

Which is way simpler to do since the people actually tell you the commands one by one.

The issue is, they dont seem to work for me.

Look at the 2 pictures below:

Please tell me what’s wrong with my commands and what I should type instead, this qubes thing is my nightmare for weeks now…