Qubes OS doesn't boot at all (Dell XPS 8940)


I come from Zorin OS (Ubuntu,Linux) and wanted to install Qubes OS for a week now but despite searching everywhere for an answer that works i decided to finally post here in hope of someone helping me for my case.

My PC specs :

Graphics card: GeForce RTX 2060 Rev. A (I don’t know if that really matters in this case)
PC model: Dell XPS 8940
BIOS (UEFI only): 2.4.0 (latest)

My problem:
I flashed Qubes 4.1.0 with multiple etchers, used dd command on a 32GB USB key, I go into my UEFI and only get the following: (sorry for the low quality of the picture)

I then tried every single option but no matter what I am welcomed by a black screen that lasts forever (i waited over 20 mins).
I have no idea what to do, I tried everything i found online, and each time i did something and it didn’t work I kept on wiping the USB disk and flashing Qubes 4.1.0
Tell me if this is a dupe, I’ve searched around myself but wasn’t able to fix my issue even tho there’s tons of similar ones to mine.
Hope someone can help me, in the meantime, have a good day and take care in those hard times.

I don’t want to discourage you, but you might want to read this

I am using an “Intel Corporation Comet Lake series” (seen using lspci command) and on the Intel website I searched for my " Intel® Core™ i7-11700 Processor" and found the following:

Does that mean I can still use OMMU I/O virtualization functionality as you said on the previous thread?

Edit: after looking at my UEFI I checked and had this already ticked.

There is a very similar model in the HCL: Hardware compatibility list (HCL) | Qubes OS. You could probably try to ask the author of the report and check if the report has some helpful details.

Also, maybe check

Sadly that person is using a desktop with legacy boot available, which is no longer supported in newer version, I just cannot access it nor is it even available anymore on newer desktop.

I have, Ive done all the troubleshooting possible that I found. Sadly nothing seems to work.

1 Like

After countless tries over the course of 3 weeks I found a way to finally boot Qubes on my machine.

I used the version 4.1 build 20220305-kernel-latest
(I will try to find the link i used to the list of all the iso i found, it was from qubes themselves but i cant find it anymore, anyway ill keep looking for people who had the same issue i did)


Great! Don’t give up, It’ll be rewarding more than you can imagine, I can tell now seeing how persistent you are!


Here’s the link for anyone having trouble installing any kind of version of Qubes on a brand new machine.