Blank screen after: (XEN) Xen is relinquishing VGA console

Hello all.

I’m trying to install Qubes R4.1 with no success so far. HW is quite new (yes, everything is enabled: VT-x, VT-d(EPT) …).
ISO boots just fine to the boot menu, but i can’t get to installer. There are no errors in Xen log - everything seems fine (memory allocated, Dom0 prepared, etc.). Xen stops at: “(XEN) Xen is relinquishing VGA console.” System pauses for a second, then screen is filled in black color, starting from the top of the screen all the way down to the bottom line. After that, nothing happens and i’m left with a blank screen. Monitors are not put into the sleep, and keyboard is also active (i can reboot with ctrl+alt+delete).

I’m suspecting video card (intel integrated UHD graphics), since it’s quite new and it’s only supported in kernel 5.16 and up.

Well, any kind of help is appreciated.
Thanks, MaPo


Thanx to Maxny in this thread: Qubes OS doesn't boot at all (Dell XPS 8940) - #7 by Maxny

Yeah, it was GPU. I booted with Qubes-20220312-kernel-latest-x86_64.iso with kernel 5.16 and everything works now.

Downloaded latest kernel builds here:

Btw, does anybody know who’s archives are those? Seems they are on a weekly schedule…

Case closed.
Again, thanx to Maxny (i own you a beer, man ;))


Thanks for posting here the solution :slight_smile: this is always great so others with the same problem know what fixed it.

Glad it worked for you!