Qubes OS 4.2.0-rc5: network error and other errors


in the past, I installed Qubes OS R4.0.X (for some X I cannot remember) for fun and everything I tried out worked fine (including Internet connection).

Today, I decided to install R4.1.2 with defaults on the same machine. The installation and configuration process went fine but one of the last steps: Setting up network didn’t seem to work. I got an error message I cannot remember exactly but I’m quite sure it’s the one I reproduce below in this post.

After clicking the message away, Qubes OS started and I logged in. But starting the sys-net VM failed – again with the same error message.

So, I decided to install R4.2.0-rc5 but I got a similar error message again. After logging in immediately after installation, I got the same error message again when starting the sys-net VM. This time, I copied the error message, reproduced here:

qrexec-daemon startup failed: 2023-12-01 13:12:30.644 qrexec-daemon [20053]: qrexec-daemon.c:144:sigchld_parent_handler: Connection to the VM failed

In addition to that error: I rebooted Qubes OS and then I

  • could not start the Q-menu,
  • missed some tray icons,
  • could not start any qube,
  • could not shut down Qubes OS cleanly.

However, I can open a dom0-terminal.

So, what can I do in order to make everything work?

Thank you for your help!

Kind Regards,
Tobias Killer

Your system seems to be pretty broken. How did you flash the Qubes ISO (software and options)?
In sys-net settings, do you have any PCI devices selected in the Devices tab? Can you start the qube if you remove that device from there?

Hello DVM,

thank you for your quick reply. I started Qubes OS again and was suprised that the Q-menu could now be opened and the tray icons re-appeared. So, I removed the Wireless Network Adapter from the device list of sys-net and it worked! (I now remember that Wireless Networking didn’t work at all in R4.0.X, probably the adapter was not detected.)

To the Qubes OS developers: I propose to remove failing network devices from the device list when setting up network configuration / sys-net during installation.

Oh, and I used ddpolymerase, my own tool for copying, repairing and verifying files (like ISO images). :wink: After your reply, I successfully re-verified the installation medium with it. Also, the self-test of the Qubes OS installation medium said that everything is fine. So, I consider three reasons for the weird behavior (like the non-openable Q-menu):

  • the issue with the Wireless Network Adapter during the installation process (configuration stage),
  • rebooting Qubes OS,
  • remains from the previous Qubes OS installation.

Kind Regards,
Tobias Killer

If this is related to the network card, add it back to the selection and enable “strict reset” for it (it’s a button at the bottom of the same tab). Restart sys-net and see if it runs without crashing.

Done. But crashing. :frowning:

I tried to reproduce the weird behavior by rebooting Qubes OS but now it seems to work.

Is sys-net working too?


Can you share the reference of your network card?

It only works if the Wireless Network Adapter is not in the device list.

Network Controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter

Is that the reference?

Yes, thank you.
Can you also provide both guest-sys-net.log and guest-sys-net-dm.log too? Get them from dom0:

qvm-copy-to-vm [qube name] /var/log/xen/console/guest-sys-net.log
qvm-copy-to-vm [qube name] /var/log/xen/console/guest-sys-net-dm.log

You can also copy to the clipboard using Qubes Manager. Right click on sys-net, choose “logs” and copy/paste (ctrl + shift + v) here with the “Copy to global clipboard” button.
Don’t forget to put them in a formatted text block.

The log files are a lot too large to paste here as text. Only 64000 chars per post are allowed. What is here the usual (secure) way to circumvent that limit?

Try uploading the .log files directly in your reply, it should work.
Or upload the content to a paste site like https://privatebin.net/ for example.

Found the button. :slight_smile:
guest-sys-net.log (1.3 MB)
guest-sys-net-dm.log (758.2 KB)

Note that I changed the timezone.

Thank you for the files.
From what I can see, the driver is loaded, but it crashes.

rtw_8821ce 0000:00:07.0: Firmware version 24.11.0, H2C version 12

You can try the following:

  • Install Qubes 4.2 rc5 with kernel-latest selected in grub
    • I saw in the logs that you are using kernel version 6.1.62-1.
  • Blacklist the related module rtw88_8821ce and install another driver manually:
    • GitHub - tomaspinho/rtl8821ce
    • If you decide to install the driver, you will need to set sys-net kernel to “provided by qube” in the settings
    • Install the driver in the sys-net template (fedora-38-xfce by default)
1 Like

Thank you, DVM, for your support! I re-installed Qubes R4.2.0-rc5 with “kernel-latest” option but the error remains. Compiling and installing a driver manually seems too sophisticated to me for now (even though I’m a developer). And since my wired ethernet works … I don’t need WiFi for now. It’s not urgent. Maybe, I’ll think about it later.

Thank you!

1 Like