Qubes OS 4.2.0-rc3 is available for testing

How do you configure split-ssh from the GUI?

I found a pretty nasty bug, I wonder if someone is able to trigger it? On 3 Qubes OS 4.2-RC3, only the one with the fresh install had this issue, but maybe it’s unrelated to upgrade vs fresh install :woman_shrugging:

1 Like

Another issue that would be welcome to confirm with other devices. Attached USB audio devices don’t have sound, except if you change their profile using some tool like pavucontrol. I have this issues on all my Qubes OS 4.2 computers, with 3 different devices.

It would be nice to mention that [qubes-dom0-current-testing] need to be enabled to update to one RC to the other one (e.g. rc2 to rc3).
(Qubes OS Global Config > Updates > Enable all testing updates).

It may sound obvious for some, but not for others.

Btw, the unstable repo update are missing in this Updates tab.
It maybe on purpose …


tanks for sharing, that’s not really obvious to me :sweat_smile:

Oh, I didn’t know that. My mistake. Thank you for pointing it out. I’ve added the missing step:

1 Like

Network password not persistent using persistent Debian sys-XYZ service Qubes with a fresh 4.2.0-rc3 installation (tried multiple times and failed every time). I’ll submit a bug report if this isn’t something else I’m missing.

could you check your wifi device is always seen as the same device?

For instance, sometimes mine is wls6 and sometimes wls7, and network manager will associate that device to the wifi network… it’s not new in 4.2

Maybe somebody who uses R4.2 can install qbittorrent inside fedora-38 and check if the icon on a taskbar is a generic cube/lock or a proper one?

Installation inside template fedora-38:
sudo dnf install qbittorrent

I want to bump this issue for R4.2.

For me it looks like qbittorrent icon colored using the AppVM color, everything looks good. Worked fine in 4.1 before too.

1 Like

So, on Fedora 38 and R4.1 it works fine for you, the icon on the taskbar in default XFCE is not a generic cube?

If that is true, I should look into my templates based on Fedora-38-minimal, maybe the issue is there.

ah, I only checked the systray, let me check again the other icons

so, with my red torrent qube based on fedora-38 template:

  • new Qube xfce menu: red qbittorent icon is there
  • old applications menu: red qbittorrent icon
  • xfce panel: red qube
  • xfce systray: red qbittorrent icon
  • alt+tab: red qube
1 Like

@solene thank you, I appreciate your work.

You mean cube, right? So, I think the bug affects R4.2.
If you try fedora-37 my guess will be you will have proper icon in these 2 cases. If you have time please check it, too. Thanks.

The answer is here:

No, I meant cube, not qube. This one: Cube - Wikipedia

oh yeah, I’m getting confused. Qubes OS’s cube icon :+1: :ice_cube:

edit: same cubic icon in the virtual desktops windows list :slight_smile:

1 Like

My bad, I thought you were talking about VMs.

1 Like

I had the same concern in the previous thread: Qubes OS 4.2.0-rc2 is available for testing - #19 by resulin


The ticket Pipewire audio support · Issue #6358 · QubesOS/qubes-issues · GitHub was not closed because the Qubes developers forgot to do it.

The answer by @Demi about this:

  • I am not sure what the documentation status is.
  • PipeWire in dom0 is not officially supported. Audio playback and recording are known to work, but features such as sound volume save & restore don’t.
  • PipeWire in sys-audio and in qubes that connect to sys-audio is fully supported, at least to the extent that sys-audio is supported at all.