Qubes OS 4.1 upgrade template based on Debian 11 from Qubes OS 4.0

Hi, few days ago I installed fresh Qubes OS 4.1 and then I restore my templates and appvm from backup from Qubes OS 4.0

After this I tried first to upgrade packages in template and then change qubes-r4.list to support 4.1 (change 4.0 to 4.1)

But when I tried upgrade my kali linux template I have this issues

And it’s not only kali linux problem because even normal debian 11 template from my old qubes have the same issues.

What do you suggest?

I know I know, I can copy Debian 11 from Qubes 4.1 and install again all packages but I don’t want do it.

you had deb-11 templates on Q4.0 ?

so you were using templates from --testing on 4.0 ?

so you didn’t fresh install deb-11 but used the existing ones from your backup/recovery?

I’m not sure that migrating of testing templates while using 4.0 to → 4.1 is supported, maybe it is, is the deb-11 heavily configured ?

Yes, I had the debian 11 template in Qubes R4 but in a stable version.

Exactly, I just wanted to use the debian templates from the backup and of course I can use them but unfortunately I can’t upgrade their Q4 packages to Q4.1