Qubes not recognizing installed RAM


I have started learning Qubes, I have done the installation, however, I cannot start any domain.

I have a 32GB of memory ram and 500GB SSD and CPU i9.

When a run the command “xl info” it only shows under total_memory: 2175. The same amount of memory also shows under the command “xentop”

Xentop output:

4 domain: 1 running, 3 blocked, 0 paused, 0 crashed, 0 dying, 0 shutdown
Mem: 2227376k total, 2157816k used, 69560k free CPUs: 8 @ 3600MHz
Name State MEM(k) MEM(%) MAXMEM(k)
Domain-0 r 1225980 55.0 1243388
sys-firewall b 325564 14.6 343036
sys-net-dm b 147456 6.6 148480
sys-net b 393256 17.7 410624

So I have not idea why Qubes is not recognizing my 32GB ram.

Thank you in advance.

(@zarkay I’ve renamed the title for what I think may be the original issue, feel free to adjust it)


Hi @zarkay ,

Is your BIOS recognize the 32GB? Go inside your BIOS setting and check.

If above answer is yes, if you boot a live Linux distribution not too recent (Debian 10 is a good candidate), is the OS recognize the 32GB?

I finally fixed it :pray: :laughing:. I don’t know what fixed it, but I have upgraded the BIOS and enabled some advanced features on my BIOS. After the reboot its works. The “total_memory” showing now is 32609.

Also, I run a “Clear RTC RAM jumper” RAM in CMOS.

Hope it helps somebody else.