Qubes Not Booting Desktop Environments

Hi there! First of all, I wanted to say that I have been a big fan of the way Qubes has been designed for a number of years. I have been a long time Linux user and have never had the hardware that I thought would run Qubes fluently. My logic was that there is no point in running it on hardware that might make it painful to use. I’ve just bought a new computer with the main intention of running Qubes. I bought a relatively cheap ‘mini pc’ in a sale from Amazon that has the following specs:

  • Ryzen 7 7735HS
  • ‎64GB DDR5

I have read over the installation guide a lot and I have changed the following settings in my BIOs: disabled secure boot, enabled IOMMU and enabled SVM. They seemed to be the relevant settings to me. The BIOS is an AMI Aptio version 2.22.1282. Unfortunately, I can’t tell you which motherbaord it has. I, (probably erroneously) presumed it would be Qubes-compatible!

The installation appeared to go through fine until I had to log into the system. I am prompted for teh disk password (as I would have expected to have been,) but upon entering it correctly, a black screen is displayed and a cursor shows for about 30 seconds, but then the computer ceases to output any signal to the monitor. This now happens every time I try to boot the computer.

I feel like such a noob and I must have missed something very basic to do with virtualisation or something because I was expecting a desktop environment to be displayed. I think I must have got a bit ahead of myself because I was looking into installing a VPN cube etc already! My worry is that it doesn’t work and I’ll have this computer running debian Mate which would be absolutely ridiculous! Haha.

I hope you can provide some advice.

Thanks a lot,

When you get the GRUB menu, hit e to edit the boot options and remove the quiet - that should give a bit more debug-info.

Do you know which graphics card you have in the machine?

Did you complete the “INITIAL SETUP”?


I will try pressing e first thing tomorrow for the debug info.

If, by ‘INITIAL SETUP’ you mean everything up to booting into a desktop environment, then yes. According to the installer, they completed installing. I have to assume that the graphics are integrated rather than discreet.


EDIT: an integrated Radeon 680M apparently.

The installer is in 2 parts

  • First part is installed when booting from the USB-stick and format the drive(s), copies the OS and installs the boot loader (GRUB)
  • Second part boots from the harddrive (HDD/SSD/NVMe/USB/…) and completes the installation by running the “INITIAL SETUP” - eg. creates the templates and configures some basic qubes

The “INITIAL SETUP” is run as part of the first boot.


Deleted post!

That’s a ‘no’ then. Thanks for clarifying Haha!

It installed them, but never booted.

Did you try to install Qubes OS 4.1 or Qubes OS 4.2? … and in either case: Did you select the default (top option) or the last (with “kernel latest”)?

If you picked the default one, you could try with the “kernel latest”.


4.2. I just used the default. I read about trying the “kernel latest” option in a similar sounding issue from an earlier release. I will definitely give that a try tomorrow. Thanks! I’ve tried multiple times so far using both Debian and Fedora as the default environments.

Choosing between Debian or Fedora only changes the default distribution used in the AppVMs. The desktop environment of the host system (dom0) is always XFCE running on Fedora 37 (for Qubes 4.2).

I’ve had a similar issue to yours two years ago, since Qubes 4.1 didn’t support the RX 6000 series of AMD cards. Back then, we didn’t have such an easy way to use the latest kernel on Qubes images, but using that option in the boot menu should fix your issue.

Thanks for the advice! For the record, pressing ‘e’ at grub, yielded the following:

insmod part_gpt

insmod ext2

search --no-floppy --fs-uuid --set=root 69907882-8d09-4008-b787-e9c\


echo Loading Xen 4.17.2 …’

if [ “$grub_platform” = “pc” -0 “$grub_platform” = “” ]; then



xen_rm_opts=“no-real-mode edd=off”


insmod multiboot2

I tried an install with the “Latest kernel” and the GUI installation stopped before I could select ‘Finish installation’. I tried a hard power off and a boot again, but the same thing happened as what I originally described in the thread.

I have just tried again (with a new ISO file and USB drive) by selecting the “Test Media and Install Qubes” and the same thing has happened… Any suggestions would be appreciated.

Thanks again,