Qubes installation on new $2,000 high end PC takes 60+ minutes to load?

I’m trying to install Qubes 4.1 to a new computer and a newly formatted nvme ssd with 100% free space (1TB). No partitions on the drive. The qubes install iso is gpg verified. I’ve installed qubes before so I’m not a complete newbie. But I got a new PC and I’m having issues. The installer takes about 60+ minutes to eventually reach the GUI installer. But the computer works lightning fast with ubuntu or Tails.

During the bootup process while waiting for the GUI installer, it displays several errors:
Failure to start udev Wait for Complete Device Initialization
WARNING kernel: nvme nvme0: I/O 24 QID 0 timeout, completion polled
WARNING kernel: nvme nvme0: I/O 92 QID 8 timeout, aborting
WARNING kernel: nvme nvme0: Abort status: 0x0

If I wait long enough (about 60 minutes), the GUI installer eventually loads. Then, it takes about 20 more minutes for the “Probing storage…” warning on the “Installation destination” box to go away. I choose my installation destination, set an encryption password, choose “automatic storage configuration”, and click Done. But it says “resource to create this lvmpv is unavailable” so I’m unable to complete the installation.

I’ve tried manually creating my own partitions using this thread: Custom Installation - FDE with Detachable /boot
But any interaction with the ssd while using the qubes anaconda terminal is so incredibly slow. I eventually had to create the partitions on a live version of ubuntu instead of the qubes installation anaconda terminal. After creating the partitions in ubuntu, the qubes installer was still slow like a sloth. It took 2+ hours just to unlock the 900GB luks partition in the anaconda terminal. I’ve been trying to install this for 8 hours. Most of the time has been spent staring at the screen waiting for it to load and respond to commands that interact with the SSD.

My hardware is a Asus ROG GU603H. Intel i9-11900H, Nvidia GTX 3060, M.2 NVMe PCIe 4 SSD.

I’m guessing there’s some kind of hardware issue that’s causing massive inefficiency with my SSD.

Can anyone help please?

1 Like

Try this iso first, https://qubes.notset.fr/iso/Qubes-20220416-kernel-latest-x86_64.iso it’s iso with kernel-latest

This is more or less expected, unless the vendor specifically targets Qubes OS (or at least Linux) with their hardware:

Not intending to offend anyone, I’ll just take an opportunity to tell how did I explained to my non-tech savvy sister why I’m using Qubes. I told her: “You see, behind this blackbox called router, it is a digital universe. And in universe and open space you can’t go in your bikini, or latest Channel gown, sitting in Bentley. You need a special vehicle and a suit if you want to walk there and live. That’s Qubes.” You might imagine how did she respond on this, hahah.

1 Like

use the latest testing version. not release. Then see. the link which @51lieal gave

Thank you. I will try this version and be sure to gpg verify it using the asc and DIGESTS files in the same directory: Index of /qubes/iso/

But where are the latest testing versions of qubes officially listed? I don’t see them on the qubes-os.org/downloads/ page. Github maybe? Which repo?

Yes very true. But in my location it’s actually easier for me to buy a new computer than an old one. I did buy the 2021 model of this laptop instead of the 2022 model hoping it would help.

Thank you @51lieal, but unfortunately that iso with the latest kernel did not work either.

dracut-pre-udev[622]: modprobe: FATAL: Module cramfs not found in directory /lib/modules/5.16.18-2.fc32.qubes.x86_64
dracut-pre-udev[673]: modprobe: FATAL: Module floppy not found in directory /lib/modules/5.16.18-2.fc32.qubes.x86_64

Failed to start udev Wait for Complete Device Initialization.
See 'systemctl status systemd-udev-settle.service' for details.

The system hangs for 20 minutes at [ OK ] Reached target Basic System.

In troubleshooting/verbose boot mode, I see:

systemd-gpt-auto-generator[1095]: EFI loader partition unknown, exiting.
systemd-gpt-auto-generator[1095]: (The boot loader did not set EFI variable LoaderDevicePartUUID.)

nvme0: I/O 25 QID 0 timeout, completion polled gets printed to the screen every 30 seconds or so

Finally after waiting about 30 minutes, I can get into an anaconda shell. TTY1 says “Not asking for VNC because we don’t have a network” but the GUI installer is available on TTY6 (control+alt+f6). If I try to proceed with the GUI installer on TTY6, I encounter the original issues of it not loading my storage configuration and it’s unable to automatically partition the drive. “Error checking storage configuration” and “resource to create this format lvmpv is unavailable”.

systemd-analyze blame
Bootup is not yet finished (org.freedesktop.systemd1.Manager.FinishTimestampMonotonic=0). 
Please try again later.

systemctl list-jobs
174 time-sync.target start waiting
173 systed-time-wait-sync.service start running
229 timers.target start waiting
238 raid-check.timer start waiting
4 jobs listed. 
lspci # shows my NVMe controller and a raid controller
0000:00:0e.0 RAID bus controller: Intel Corporation Volume Management Device NVMe RAID Controller
10000:e1:00.0 Non-Volatile memory controller: Intel Corporation Device f1aa (rev 03)

lsblk #also shows my nvme drive at /dev/nvme0n1

In my Asus bios, there is no option for legacy boot. There is also no explicit option to toggle Intel RST (raid) on or off but it says it’s already set to “off” for my drive.

Also, out of curiosity, I tried to install Fedora 32 on this PC and I ran into similar issues.

I don’t know if this would provide any more info but my issue seems similar to this issue I found on github. Similar error messages and nvme problems. However, I’m able to see my nvme drive during qubes installer whereas this person cannot. They had to change from raid to AHCI/NVMe mode in their Dell bios:

try installing fedora-35, would that do?

1 Like

Yes! Fedora 35 workstation installs perfectly with no hassles. Fedora 32 workstation does not work.

When will qubes start using Fedora 35 instead of 32? I may be willing to put this new computer on the shelf for a while and wait for qubes with fedora 35 to come out.

Fedora 32 is not used already (unless you forgot to upgrade your TemplateVM).

Try search a workround or wait till qubes update dom0.
There’s not much we can do, many people here who use latest cpu available in the past (10th gen) has just begun their qubes journey in 4.1

same problem after i update my bios.

systemd-gpt-auto-generator[1133]: EFI loader partition unknown, exiting.
systemd-gpt-auto-generator[1133]: (The boot loader did not set EFI variable LoaderDevicePartUUID.)

and then,

nvme nvme0: I/O 17 QID 0 timeout, completion polled
nvme nvme0: I/O 25 QID 0 timeout, completion polled
nvme nvme0: I/O 18 QID 0 timeout, completion polled
nvme nvme0: I/O 26 QID 0 timeout, completion polled
nvme nvme0: allocated 64Mib host memory buffer.

and it’s taking very long time to boot,still booting.

Try disabling SMT. Hope it works for you as well

I’m dealing with the same issue and trying to deal with it by building my own ISO with different NVME drivers. . . but I’m running into different road blocks with that. My BIOS doesn’t seem to support disabling SMT. Any other ideas?

Fedora 36 works fine on this machine.

I found the answer, thanks to u/Gryxx1 on the Linux Questions subreddit (yeah, I’m not linking to reddit’s “new” interface, deal with it reddit). It’s a weird work around, but after MUCH tinkering, it worked for me.

Here’s what I did.

1. Booting from a totally different computer, install Qubes onto an external hard drive of the same size as the NVMe drive (1 TB in my case) . Stop the install after the first reboot and go on to step 2.

2. Boot the problem laptop using the external drive. I had to use the boot menu to boot from an EFI file to get it to boot this drive, but boot it did.

3. From this drive, do the rest of the install / configuration. For me, this meant letting it sit all night with a blacked out screen and no keyboard or mouse input. I don’t know what Qubes is doing, but it takes hours and hours and your drivers are disabled for some of it for some reason. More than twice I made the mistake of getting impatient, thinking it had hung and rebooting. This corrupts the drive and go back to step 1. If I hadn’t read people on the internet saying “let it sit all night,” I would have assumed this strategy just wouldn’t work and the system was hanging.

4. Once this is done, you can do configurations and troubleshooting if you want, but I don’t recommend it because Qubes runs like a snail when you’re using an external drive as your hard drive. So just use a live USB to boot the laptop into something else (I used Mint 20, because it comes with GParted out of the box) and then use dd to clone the external drive to the NVME drive. Given I’m using dd to clone a terabyte block device to another terabyte block device, this ALSO takes all night. . . and now if I have to start over it sets me back two days! Yippy! (I had to do this once already when I broke sys-net trying to install wifi drivers, now I seem to have broken sys-net again, trying to install wifi drivers FML)

So there you have it folks, a stupid workaround that gets you functioning Qubes on your Intel PoS NVMe drive (this is happening on a brand new HP laptop, amirite?)

Now that I’ve gotten you here, to the point where it’s installed and working, you can spend more days / weeks troubleshooting your driver issues that come up trying to run Qubes on a brand new made in China high end consumer laptop. But it’s about the journey not the destination, right?

Speaking of - an additional quirk: I STILL have to use the boot menu to boot from an EFI file to get it to see the NVMe drive as a boot device (otherwise the BIOS just complains about there being no operating system). As an extra plus, the BIOS doesn’t give you any drives to select to look for the EFI file on unless there’s a bootable USB plugged in lol. This could probably be fixed, but I just consider it an “extra security feature.”

You need to add EFI boot entry:
If your device is /dev/nvme0n1 and efi partition is 1 then :
efibootmgr -v -c -u -L Qubes -l /EFI/qubes/grubx64.efi -d /dev/nvme0n1 -p 1

1 Like

Hi I’m super noob in qubes but I hope this helps someone.

Hi I had the same problem. I fixed it by changing the hard disk mode in my BIOS.
It was configured to use RAID, after disable this all worked like a charm.

BTW I’m using a dell Inspiron 15 with an I7.

1 Like