Qubes efi breaks after booting windows drive (Not dual boot)

Installed Qubes 4.1.2, works fine, shut down reboot install software all good.

On same PC I physically removed Qubes hdd and replaced it with a Windows hdd. Booted into windows. After removing Windows hdd and putting back Qubes hdd it will not boot, Is asking for proper boot media.

The drives were only installed and turned on one at a time (not dual booting and physically swapped). So I really cannot understand why Qubes refuses to boot.

Reinstalled qubes and did the same physical swap again to test it…same result qubes will not boot and required propper boot media after windows is booted once.

What could be going wrong and how do I get Qubes to boot ?


1 Like

secure boot disabled, same issue.

It is only when the hdd is removed, windows hdd is booted into, and then qubes is put back into the pc that I have an issue.

Otherwise Qubest works without issue.

One single boot of windows and it is game over for qubes. I cannot understand this.

efibootmgr may need to be corrected. Windows probably deleted your Qubes boot entry. There are quite a few EFI related posts in the forum that should cover how to check and update.

Edit to add Docs page:

Edit to add another forum post:

1 Like

I physically disconnected the qubes hdd, then connected win hdd and booted.

Do you think it may be something else ? I dont see how that file could be deleted or altered if the qubes drive was physically disconnect. What do you think please let me know?

The second thread linked solved problem! Thank you. Perhaps guide can be updated for 4.1.2 for any user facing a similar issue. Is there I way I can help do that ?

1 Like