Qubes-Dom0-Update not functioning and upgrading

Hi folks,

I run qubes-dom0-update and it downloads the things that it needs to.

After that it says it needs to shut down the running virtuals to be able to perform it’s update.

To this I say yes to do it, because I’m wanting to update to try to maybe see if there are bugs to be fixed.

Then it tells me that the system needs to restart as it is upgrading to XEN 4.17.

This is when I say Y to restart. After it restarts, I run the update again, and it keeps doing the exact same thing.

I’m getting frustrated with an operating system that won’t update.
I know that it may need to restart to update the kernel, but it should not need to restart until everything is installed.
It should be installing the kernel and then restarting and having it as the functional kernel. All the rest of the software doesn’t need a restart to do though.

I even tried to just do the qubes-manager, but ti still said all the same things.

Help would be greatly appreciated.


Sorry, Misread it earlier…
It’s trying to DOWNGRADE, even though it says UPGRADE…

]$ qubes-dom0-update
Using sys-firewall as UpdateVM to download updates for Dom0; this may take some time...
WARNING: Attempting a major Xen upgrade (4.14 -> 4.13) while some qubes are running
WARNING: You will not be able to interact with them (not even cleanly shutdown) until you restart the system
List of running qubes:
sys-firewall   Running  DispVM   green  debian-11-dvm  sys-net
sys-net        Running  DispVM   red    debian-11-dvm  -
Do you want to shutdown all the qubes now? [y/N]

I’m not sure I understand what you’re trying to do here. qubes-dom0-update is not meant to be used for this kind of thing. What is your goal?

Firstly, I would ask that you look at what it is that you are asking…
Secondly, Read my details…
Third, Think about what “qubes-dom0-update” does.
Fouth, rethink what you ask and say.
Fifth, let someone that knows what they are talking about answer if you have nothing helpful to contribute.

Your main post is not clear at all, you don’t say anything about what you did before that would explain why you are going through a major Xen downgrade, so I was confused and asked for clarification.

About your nonsense response

I don’t understand why you get so rude when I ask for details to actually help you fix your problem? If that’s the way you want to play it, so be it, but don’t come on this forum and use those kind of words out of nowhere to people who are volunteering to help find the root cause of your problem. I’ll let others judge for themselves if you’re worth helping after that, but personally, I’m out.

It’s actually very clear.
I told you everything, even provided the text details…

How can you NOT understand that I’m running “qubes-dom0-update” and it’s doing what I said it’s doing?

What part of it is not clear?

Howdy peeps, anyone have any thoughts on this one yet?

I’m stil having issues with qubes-manager and want to update it, but I can’t until this issue gets resolved.

Does noone else have this issue at all?
Or ever had this issue?

As per documentation:

Advanced users may wish to perform updates via the command-line interface. The recommended way to do this is by applying the following two Salt states. Applying these two Salt states is the same as updating via the Qubes Update tool.

In your update qube, a terminal window opens that displays the progress of operations and output as it is logged. At the end of the process, logs are sent back to dom0. You answer any yes/no prompts in your dom0 terminal window.

So what about that documentation?
If you don’t have anything that is actually trying to help or resolve the issue or assist in finding out what the root cause of the issue is, then why mention the DOCUMENTATION when the DOCUMENTATION does NOT mention anything about it?

So how about you READ the problem, and READ the issue, and READ the comments BEFORE you say something that has nothing to do with anything???

My gawd… Why can’t people READ?

1 Like

Moderation note

I’ve enabled slow mode on this topic to give everyone time to calm down and reflect what their posts are bringing to the conversation.

Please everyone remember that ad-hominem attacks won’t be tolerated, and that personal back and forth doesn’t bring anything useful to the rest of the people who may be interested in the issue.

Well, having the same issue again with updating on this installation.

You get to a point in time of updates and it just tries to reverse from 4.14 to 4.13.

This is just ridiculous… It NEEDS to be fixed…

Check the dnf log to see at what point did it go wrong and started to suggest the xen downgrade.
You can see the log in dom0 /var/log/dnf.log or /var/log/dnf.rpm.log.
Perhaps you’ve installed/tried to install some package that is causing this dependency issue.

There shouldn’t be anything.
I was only trying to install something from the QEMU packages, and that wasn’t going to do anything to XEN. It didn’t even download anything for XEN.

dnf.log merely states that it was trying to install the package I was trying to install.
dnf.rpm.log just has the fact that I installed a few bits ages ago, and multitail more recently.

But these are things I did on the old drive before that had the issue.

But on that one I was NOT trying to install anything for QEMU, I only did a qvm-dom0-update and left it at that. So it was only updating what was already installed which was pretty much a generic system, just made more secure by configuration.

Hi Drew
It would be very helpful if you could provide details about the
packages that you are trying to install, and the exact command line you
are using that gives rise to the issue.