Qubes-dom0-update doesn't seem to work after upgrade from R4.0

I upgraded my R4.0 installation to R4.1, I noticed 2 things:

  • When I execute qubes-dom0-update, the sys-whonix window appears and checks for updates, when it is done it immediately disappears. I filmed it with my phone and found that it outputs:
Removing dependent packages:
* a number of python2 packages * 
Transaction summary
Remove 14 packages
Freed space 14MB
DNF will only download packages for the transaction

Then dom0 terminal reports no updates found. Shouldn’t it ask about removing those packages?

  • When I try to install a package with qubes-dom0-update, the sys-whonix window closes early and I get an error about downloading the metadata for the cache repository:
Using sys-whonix as UpdateVM to download updates for Dom0; this may take some time...
Qubes OS Repository for Dom0                    0.0  B/s |   0  B     00:00    
Errors during downloading metadata for repository 'qubes-dom0-cached':
  - Curl error (37): Couldn't read a file:// file for file:///var/lib/qubes/updates/repodata/repomd.xml [Couldn't open file /var/lib/qubes/updates/repodata/repomd.xml]
Error: Failed to download metadata for repo 'qubes-dom0-cached': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

Check this issue, there are some instructions to fix this problem:

It doesn’t seem like the same issue. When I run sudo qubesctl --show-output state.sls update.qubes-dom0
I do get the warning:

[WARNING ] /usr/lib/python3.8/site-packages/salt/utils/files.py:396: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used
f_handle = open(*args, **kwargs) # pylint: disable=resource-leakage

But not the error about module localemod, and after the warning, the update reports system is already up to date.

I tried anyway to remove python2 packages, used the commands to clean salt cache, removing qubes-mgmt-salt-base-overrides wasn’t necessary because it was already no longer installed, default kernel version already was 5.10 and kernel-devel is not installed.

I still have the same issues with qubes-dom0-update.
Switching the UpdateVM from sys-whonix to sys-firewall(fedora-35 template) also does not make a difference.

Here was the same error:

But there was no solution.


Thanks, I replied there.