Qubes_dom0-swap showing up as Data Block Devices. Normal?

Should this swap file be showing up here?

Are there any commands to make this stop?

1 Like

I see this in 4.1 too. It looks like a bug. I dare not click it.

@unman @sven any reply? still not sure what this is.

I don’t know what to reply to.
Where is “here” that the swap file shows up? Please describe the issue
in more detail.

The yellow icon showing Qubes Devices has 3 sections nows.

Data (block) devices

Audio Input

USB Devices

Under Data (block) devices, it shows qubes_dom0-swap as an actual device that I can attach to various qubes. It has a crown next to it and it is large in size, showing 2.9 GB

I’m guessing this isn’t normal or good or should have be wanting to have there?

What is the output of the following two commands in dom0?

grep swap /etc/fstab




grep swap /etc/fstab

/dev/mapper/qubes_dom0-swap none                    swap    
defaults,x-systemd.device-timeout=0 0 0

swapon does nothing, it just goes to next line

is this good?

If swapon gives no output, it appears swap is disabled in dom0 for some reason.

Is there any fix other than a reinstall?

swapon -a seems to fix it for me.