"Qubes-dom0-root" does not exist after adding another LUKS2 disk password (that works)

Hey! I need some serious help. I have been locked out of qubes after adding a LUKS2 encryption password, which works but when I enter my old one or this new one - I get this screen:

What do I do now? I have no idea. Please help me. All I did was add another LUKS password and it is working. I don’t see why this would happen.

Would really appreciate help.

Thank you

Try to boot from some LiveUSB OS and decrypt your Qubes OS encrypted LVM there. Check if the LVM is present after decryption.
Maybe you’ve entered some wrong commands to add another password and formatted your drive by mistake.

Alright. Can you explain “decrypt your QubesOS LVM there”? And check if the LVM is present after decryption? What is LVM?

Appreciate it a lot.

I am 99% sure I did not enter any wrong commands which is weird. The process was quick and without issues. But maybe…

What guide did you follow? Or what commands did you execute?

Really just using cryptsetup:

1 lsblk

2 found the right one - sda2

3 sudo cryptsetup luksAddKey /dev/sda2

Then followed the on screen instructions and did not get any errors. Double verified the password and it worked. It is very weird. Maybe I have deleted some important TemplateVM or something? Could be a possibility since I did rinse some stuff yesterday but honestly I was 100% careful so don’t really see how that could happen…

Is this not looking good? I might lose a lot of progress

Update: When entering my disk password in the boot up menu, it takes about 4 tries for it to work even though the password is right. Very weird. Maybe I should have removed the old password and just use the new one since they might mess things up with each other.

Also just realized that that would be a lot of lines. Maybe not…

I did find this might be relevant:

Well, seems like the password is incorrect.
Try to decrypt it from some LiveUSB OS.

That is the weird part. Like I said, I have the old password which still works and the new that still works. However I have to enter them multiple times before they “work” or at least get past the disk password screen to boot, but then the error comes. Does a wrong password take me here to this screen as well? I will try it.

Okay I will try it

If you have more than one LUKS volume, you need to change the password on all of them.

Possible man. I maybe have two.

Sda1 - 2 gb
Sda2 - 900gb

Both might be under luks but I dont remember exactly.
Or luks might be under sda2 only, then followed by qubes and everything in it.

"Boot in a live usb (even the Qubes OS installer, enter TTY with CTRL+ALT+F2) and deal with the qube in question from there.

If your QubesOS installation is encrypted:

$ cryptsetup open /dev/ luks-qubes

Find the name of the qube of interest and mount it

$ lsblk

Grep can help you locate the exact qube

$ lsblk | grep
$ mount /dev/mapper/qubes_dom0-vm––private /mnt

Do what you need to do then unmount

$ umount /mnt
$ vgchange -a n
$ cryptsetup close luks-qubes
(you may need to run the above as root)


Do you think this could work? With some configurations. Will try

Update: I typed a “9” as a “g” in my password notebook and mixed them up. Holy sh*t i paid for that. 3 hours of pure good quality time.

Problem solved, you were right after all. :smiling_face_with_three_hearts: