Qubes Disk Encryption Password stopped working

I installed Qubes 4.2.1 a couple (3-4) weeks ago, and been using it every other day.

An hour ago I tried to boot my system, and my password just won’t unlock the disk :frowning:

I rebooted for a countless amount of times and tried my password for at least 20 times, it just won’t work. I am 99% sure that this is my disk password.
Could something be wrong in the system?

Maybe you have CapsLock enabled?
You can try to boot from some Live OS and try to decrypt your Qubes OS disk there for a test.

Thanks, just tried it.
Looks like the password has somehow changed :expressionless:
and it’s not just when booting trough Qubes.

Gonna have to figure out what the heck happened…

The following assumes you are using a laptop.

Check your keyboard and clean things up with compressed air. Activate keystroke visibility, if possible (in a save environment, if necessary) when unlocking luks. If everything seems ok (I.e. every keystroke gets registered) and you still can’t unlock, try to boot some minimal distro from stick, open some terminal and type as you would to unlock. Just to make sure your keyboard is ok. If not, check again with some (external) keyboard.

If everything else fails: unplug the charger, remove the battery and press power button for some secs. Insert battery and plug in charger. Retry.

I just booted a Live OS from a USB, tried unlocking the drive with no luck.
The password is 100% correct, I use it for another OS that works just fine, and its a simple word chain. No room for mistakes…

I am very sure now that there is something wrong with the drive probably.
What can I do instead if my battery is not removable?

Are you sure, the keyboard is actually transmitting the right code?

On the live boot, I typed the pass into a notepad type of software then copied and pasted. So yeah should be it.

1 Like

Then - I fear - there is no use of resetting controllers by power drain. (You could have opened the case and disconnected the battery pack. But it doesn‘t seem like a hardware problem.)

The „sad“ truth is: encryption works. I never heard of a self changing passphrase.

It could be due to the LUKS header corruption, I don’t think it’s salvageable if that’s the case.