Qubes Desktop Wont Boot and Turns off all devices while autostart turned on

I have searched online for a solution, I’ve asked around. Nothing. I don’t know what to do here.

I have qubes 4.1 installed on my desktop, had it installed maybe three months. Had qubes on it for at least two years. About maybe 2 weeks ago, I set up a USB qube. Everything was working great. But a couple of days ago, when I tried to boot qubes, during the boot my keyboard and mouse lights would turn off followed by the display completely losing all input 30 seconds later. Then I just had to turn it off with the power button. So I tried instead to boot a different kernel and it worked! I thought it was fixed. Then the next day, NONE of the kernels will boot and they are all displaying this behavior. I don’t know what to do. I have tried text mode, it often happens around the time a bunch of the VMs are autostarting and it sometimes says a bunch of stuff about “USB disconnect” really fast and then goes black. I tried disabling autostart of the VMs to see if that would help, from the grub commandline, and it just started them anyways. (Edit at the bottom, I figured that out and got it to boot after turning that off. but why?)

I am at a loss for what to do. I was in the midst of doing important things on my computer, so this is really upsetting and slowing me down. It’s very important that I get this fixed ASAP as I do not have time to troubleshoot or mount the disk to a live usb and go through the files to try to find what i was looking for etc. I need this fixed yesterday. Would booting a Qubes installer USB do anything to help? Please someone provide some insight, I NEED my computer to work. This is extremely stressful for me. I do not have the time. Thank you!

Edit: I got it the default kernel to work after some fiddling with the grub commandline and turning off qubes autostart. But the question here is why cant I have autostart on? I dont want to have to start every VM when I start the computer. But more importantly, why are my usb devices still working when the usb qube isnt started up? it makes no sense that vms autostarting would make it so my display goes off? Maybe it booting this time is a fluke. Im going to make a backup right now

Edit 2: Just discovered that starting sys-usb is the culprit. But why would it make my ps2 keyboard and my display both turn off? That makes no sense! Can someone help? I checked the devices tab under the sys-usb qube and it APPEARS that only two USB controllers are set up for it and nothing else so not sure why it’d effect my display and ps2 keyboards? I turned off automatic start for sys-usb for now.

You can try and use lsusb -v to see the devices connected to the USB bus.

The PS/2 controller could be PS/2 to USB, in which case it functions are a normal USB keyboard in regard to sys-usb.

Can this possibly explain the reason for the display losing input though? It’s an entirely separate GPU, not the onboard one. That doesn’t make much sense to me, but I could be wrong. At any rate, how would I even fix this if it was the case? I will check very soon.

This looks like very important, missing info…

Non-technical intro

Well, take a few deep breaths and we will work through it.

In the midst, you say, my lord esquire? Tech support, what ho!

If your computer won’t boot, I’d say you haven’t just been slowed down. You’ve come to a complete stop…

I never would have guessed…

Right…Packed schedule and what-not…

Well then you’d better not create a USB qube on your time machine, otherwise you might not be able to travel back in time to yesterday. At least until we have figured this out…

Didn’t you literally just say that you “do not have time to troubleshoot or mount the disk to a live usb and go through the files to try to find what i was looking for etc.”?

  • Patience is a virtue.
  • You catch more flies with honey than you do with vinegar.
  • The Boy who Cried Wolf is a great fable

You think this is stressful for you…? You should see it from our end…

Who really does have the time, y’know?

You’re most welcome!

Ok, now that we got that out of the way…

Honestly, that sounds like your USB qube being started by systemd, and then your display turning off because of no input being given…

I noticed that you found that out, and were able to stop your USB qube from autostarting, which is good.

There’s no reason why you can’t have autostart on at all. We just have to figure out why it’s causing you grief, rectify it, and then you can have autostart back on again.

@renehoj said it. Maybe check your BIOS settings. There is a chance that your PS/2 controller is also doubling as a USB controller.

@hugequbesissuehelp, logs and hardware information would make this a 2-minute conversation, and get your computer back a lot quicker…

Any chance of you posting some of that?

I put your introduction into a dedicated spoiler, to keep the discussion more tidy. I hope you don’t mind.

I like it, actually. It makes my point even clearer.

Now all we are waiting on is that key info so that we can get this issue solved.

@hugequbesissuehelp, any update?